summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-30 07:55:11 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-30 07:55:53 +0200
commitf1640239854806349abfed2b8f79ca8897011ab2 (patch)
tree9aaec0f8c82a03d78c7237c7d4b633c329083924 /dev-ml/ocamlgraph
parentapp-admin/puppet-lint: enable ruby33 (diff)
downloadgentoo-f1640239854806349abfed2b8f79ca8897011ab2.tar.gz
gentoo-f1640239854806349abfed2b8f79ca8897011ab2.tar.bz2
gentoo-f1640239854806349abfed2b8f79ca8897011ab2.zip
dev-ml/ocamlgraph: add 2.1.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlgraph')
-rw-r--r--dev-ml/ocamlgraph/Manifest1
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-2.1.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/Manifest b/dev-ml/ocamlgraph/Manifest
index bb22ec3f3bd8..7ad20d116b3d 100644
--- a/dev-ml/ocamlgraph/Manifest
+++ b/dev-ml/ocamlgraph/Manifest
@@ -1 +1,2 @@
DIST ocamlgraph-2.0.0.tbz 298912 BLAKE2B a4bb04c74f4dba8b0f37cdf8ab9a82ef5120b1e7f5b5570e67aac35de16e4553c93759acfa5c218e07dc7c036750d92d2c557c7d58247783718f691c5319ded8 SHA512 c4973ac03bdff52d1c8a1ed01c81e0fbe2f76486995e57ff4e4a11bcc7b1793556139d52a81ff14ee8c8de52f1b40e4bd359e60a2ae626cc630ebe8bccefb3f1
+DIST ocamlgraph-2.1.0.tbz 311740 BLAKE2B 938def0cfce8ad5c2d47058bf533715cf9359d25ea968ceeb2959cb968e08a9acf442e21cd16c1e93df1919177c01105c1139c71be6e53c6e1b22aa511e2619f SHA512 8ee77bc1ef27bef41171b5718a73342dca8adc4b4592ff835038cd21e8c91152a0f9500b4034f664d1db7a09dab1efcc3be5d7c59260d6b33710b82a1fb2f196
diff --git a/dev-ml/ocamlgraph/ocamlgraph-2.1.0.ebuild b/dev-ml/ocamlgraph/ocamlgraph-2.1.0.ebuild
new file mode 100644
index 000000000000..9ed28c085ec3
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-2.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="https://github.com/backtracking/${PN}/releases/download/${PV}/${P}.tbz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+RDEPEND="
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ dev-ml/graphics:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+IUSE="+ocamlopt"
+
+src_compile() {
+ dune-compile ocamlgraph
+}