summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:02:13 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:29 +1100
commitdd72f739f9f9d3598ad7505252f36d6167776a44 (patch)
tree7679129e7570989eeb63fbef26ecdc4bb9352eeb /dev-ml/opam-core/opam-core-2.0.7.ebuild
parentdev-ml/opam-client: Dependency of dev-ml/opam (diff)
downloadgentoo-dd72f739f9f9d3598ad7505252f36d6167776a44.tar.gz
gentoo-dd72f739f9f9d3598ad7505252f36d6167776a44.tar.bz2
gentoo-dd72f739f9f9d3598ad7505252f36d6167776a44.zip
dev-ml/opam-core: Dependency of dev-ml/opam-format
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/opam-core/opam-core-2.0.7.ebuild')
-rw-r--r--dev-ml/opam-core/opam-core-2.0.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/opam-core/opam-core-2.0.7.ebuild b/dev-ml/opam-core/opam-core-2.0.7.ebuild
new file mode 100644
index 000000000000..6834f2d578d6
--- /dev/null
+++ b/dev-ml/opam-core/opam-core-2.0.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+
+inherit opam
+
+DESCRIPTION="Core libraries for opam"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-ml/ocamlgraph:=
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+ dev-ml/cmdliner:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/opam-${PV/_/-}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9)))
+ (release
+ (flags (:standard -warn-error -3-9))))
+ EOF
+}
+
+src_compile() {
+ emake -j1 opam-installer
+ emake -j1 ${PN}.install
+}