summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-03 21:35:11 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-03-03 21:46:44 +0100
commit345286d9b59944a8eb8e7cba317cf2424169ac5d (patch)
tree2119e11d65c71bb89d07b8b424a83ea335f86185 /dev-ml/opam-core/opam-core-2.1.3.ebuild
parentsci-libs/pcl: drop 1.12.0, 1.12.1 (diff)
downloadgentoo-345286d9b59944a8eb8e7cba317cf2424169ac5d.tar.gz
gentoo-345286d9b59944a8eb8e7cba317cf2424169ac5d.tar.bz2
gentoo-345286d9b59944a8eb8e7cba317cf2424169ac5d.zip
dev-ml/opam-core: add 2.1.3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/opam-core/opam-core-2.1.3.ebuild')
-rw-r--r--dev-ml/opam-core/opam-core-2.1.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/opam-core/opam-core-2.1.3.ebuild b/dev-ml/opam-core/opam-core-2.1.3.ebuild
new file mode 100644
index 000000000000..4074055d42a2
--- /dev/null
+++ b/dev-ml/opam-core/opam-core-2.1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+inherit opam
+
+DESCRIPTION="Core libraries for opam"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
+S="${WORKDIR}/opam-${PV}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-ml/ocamlgraph:=
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+ dev-ml/cmdliner:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo"
+
+PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9)))
+ (release
+ (flags (:standard -warn-error -3-9))))
+ EOF
+}
+
+src_compile() {
+ emake -j1 opam-installer
+ emake -j1 ${PN}.install
+}