summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-08 15:37:09 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-08 15:37:09 +0100
commit9bd84e55a93799649f072c8242d0325317c0332d (patch)
treef093a4e3b78861e71d398ddd7abaca213802c691 /dev-ml/ounit2/ounit2-2.2.6.ebuild
parentsci-mathematics/mathlib-tools: add changelog link (diff)
downloadgentoo-9bd84e55a93799649f072c8242d0325317c0332d.tar.gz
gentoo-9bd84e55a93799649f072c8242d0325317c0332d.tar.bz2
gentoo-9bd84e55a93799649f072c8242d0325317c0332d.zip
dev-ml/ounit2: bump to 2.2.6
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/ounit2/ounit2-2.2.6.ebuild')
-rw-r--r--dev-ml/ounit2/ounit2-2.2.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ounit2/ounit2-2.2.6.ebuild b/dev-ml/ounit2/ounit2-2.2.6.ebuild
new file mode 100644
index 000000000000..b454e94dc082
--- /dev/null
+++ b/dev-ml/ounit2/ounit2-2.2.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="https://github.com/gildor478/ounit"
+SRC_URI="https://github.com/gildor478/ounit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ounit-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/lwt:=
+ dev-ml/stdlib-shims:=
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dune-install ${PN} ${PN}-lwt
+}