summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-14 19:20:08 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-14 19:24:07 +0200
commit876005b496d042cc5801a539511495a0c6fc77cf (patch)
treeddb81c4503377a57dcbeba1cda0f2c5e4631ca97 /dev-ml/ppx_module_timer
parentdev-ml/ppx_optional: add 0.17.0 (diff)
downloadgentoo-876005b496d042cc5801a539511495a0c6fc77cf.tar.gz
gentoo-876005b496d042cc5801a539511495a0c6fc77cf.tar.bz2
gentoo-876005b496d042cc5801a539511495a0c6fc77cf.zip
dev-ml/ppx_module_timer: add 0.17.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_module_timer')
-rw-r--r--dev-ml/ppx_module_timer/Manifest1
-rw-r--r--dev-ml/ppx_module_timer/ppx_module_timer-0.17.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_module_timer/Manifest b/dev-ml/ppx_module_timer/Manifest
index 7c29815a6e51..34708dc19518 100644
--- a/dev-ml/ppx_module_timer/Manifest
+++ b/dev-ml/ppx_module_timer/Manifest
@@ -1,3 +1,4 @@
DIST ppx_module_timer-0.14.0.tar.gz 7262 BLAKE2B 6fafc6b4b449071f4a95619d078814b0c3ace3574df46585b72549e5db349ab476124c217f46c6903c7c8a059f779dc62cc8a079eb1ef6b4854646fdabdf04bf SHA512 cd9b6bbd6461b7408a31a0f6ca010a3c755db1f4a22150645c530e7b4a0a4c76a308ad0f8aeddc54914a116f6d74bd738604cfd9d9d255197f9ea18904d715e7
DIST ppx_module_timer-0.15.0.tar.gz 7242 BLAKE2B 66c2bfbfcfc594ab568dd30cf874fea213fe8d72f23dbd9b56957ba95a8a01bcb8cb8f98ea42b399bad3afdba1c14edb5087a95720c87e22c865538166af4cf6 SHA512 4cd55dce6872cbed1d34c34043500651e605c406747914173584cee1d8f3ff298a75efeb8a4beb7840df76b5d7c7db98d15399d3c4a3a5dca2a11d57339df6de
DIST ppx_module_timer-0.16.0.tar.gz 7281 BLAKE2B 3be0d87198cb15c7a95b8b72648a8e986c6ef83dd173538931f8fc9426bc6bf384c76f62dea7440d637caa40548e19832da07c32528c46c3eca10d354a0a98a7 SHA512 6125aec05e91bb11d1b41fc4fb9a1030561403c7f27ea9d9512a6050da4cfdc796cfe3acb1d96e5333f65b6beab6f5b16b044529ccc6e99e90c019923adf85d9
+DIST ppx_module_timer-0.17.0.tar.gz 7315 BLAKE2B c960f023a94cd8f48be6fb4bd5ae6c07ab244d25fee9a279888679b7c60a0188e64ec0f999106b84abd4e5b78ce5267c8bdf6e4e63b17f4de07d3b363879b226 SHA512 205506db24d42340cf0a1b6c5c58cfc96835c15b4948ca30aa87d237010569ab9cd23792f12ac4dc5402e8ed681038a39db99ca0eb4117cc91794266fc3b32d4
diff --git a/dev-ml/ppx_module_timer/ppx_module_timer-0.17.0.ebuild b/dev-ml/ppx_module_timer/ppx_module_timer-0.17.0.ebuild
new file mode 100644
index 000000000000..a0e78ac596b3
--- /dev/null
+++ b/dev-ml/ppx_module_timer/ppx_module_timer-0.17.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Ppx rewriter that records top-level module startup times"
+HOMEPAGE="https://github.com/janestreet/ppx_module_timer"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ dev-ml/ppx_base:${SLOT}[ocamlopt?]
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+ dev-ml/stdio:${SLOT}[ocamlopt?]
+ dev-ml/time_now:${SLOT}[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"