summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-09 22:28:14 +0000
committerSam James <sam@gentoo.org>2021-02-09 22:47:42 +0000
commit8cb319f9a5845c6c0068da9cf8c98f67b8fdc01a (patch)
tree70753cd5efcfdf3695cc6be977fb8811eff91227 /dev-ml/uuidm/uuidm-0.9.7.ebuild
parentwww-plugins/chrome-binary-plugins: automated update (90.0.4412.3) (diff)
downloadgentoo-8cb319f9a5845c6c0068da9cf8c98f67b8fdc01a.tar.gz
gentoo-8cb319f9a5845c6c0068da9cf8c98f67b8fdc01a.tar.bz2
gentoo-8cb319f9a5845c6c0068da9cf8c98f67b8fdc01a.zip
dev-ml/uuidm: new package (dev-ml/alcotest dep)
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/uuidm/uuidm-0.9.7.ebuild')
-rw-r--r--dev-ml/uuidm/uuidm-0.9.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/uuidm/uuidm-0.9.7.ebuild b/dev-ml/uuidm/uuidm-0.9.7.ebuild
new file mode 100644
index 000000000000..867adf732171
--- /dev/null
+++ b/dev-ml/uuidm/uuidm-0.9.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Universally unique identifiers (UUIDs) for OCaml"
+HOMEPAGE="https://github.com/dbuenzli/uuidm"
+SRC_URI="https://github.com/dbuenzli/uuidm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ dev-ml/findlib[ocamlopt=]
+ dev-ml/ocamlbuild[ocamlopt=]
+ dev-ml/topkg
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}