summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-16 06:46:21 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-16 13:20:45 +0100
commitc7756371d3b846e6ba93e68c53cd69ecafb57fe1 (patch)
tree6df65551dc6644fdbe3014509e7b9e8e531dba5d /dev-ml/uunf/uunf-15.0.0.ebuild
parentmedia-sound/grip: dropped obsolete 4.2.3 (diff)
downloadgentoo-c7756371d3b846e6ba93e68c53cd69ecafb57fe1.tar.gz
gentoo-c7756371d3b846e6ba93e68c53cd69ecafb57fe1.tar.bz2
gentoo-c7756371d3b846e6ba93e68c53cd69ecafb57fe1.zip
dev-ml/uunf: bump to 15.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/uunf/uunf-15.0.0.ebuild')
-rw-r--r--dev-ml/uunf/uunf-15.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/uunf/uunf-15.0.0.ebuild b/dev-ml/uunf/uunf-15.0.0.ebuild
new file mode 100644
index 000000000000..b4c38684ce6a
--- /dev/null
+++ b/dev-ml/uunf/uunf-15.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode text normalization"
+HOMEPAGE="https://erratique.ch/software/uunf https://github.com/dbuenzli/uunf"
+SRC_URI="https://erratique.ch/software/uunf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/topkg:=
+ dev-ml/uutf:=
+ dev-ml/cmdliner:="
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/findlib"
+OPAM_FILE=opam
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ # bug #798270
+ ulimit -s 11530000
+
+ ocaml pkg/pkg.ml build \
+ || die
+}