summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-07 12:04:01 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-07 12:10:30 +0100
commit9abfe7aa58c689e223de5110b0821ae3541268b9 (patch)
tree680ae08a011e0987ae5010b3795308468e652407 /dev-ml
parentwww-apps/davical: add 1.1.11 (diff)
downloadgentoo-9abfe7aa58c689e223de5110b0821ae3541268b9.tar.gz
gentoo-9abfe7aa58c689e223de5110b0821ae3541268b9.tar.bz2
gentoo-9abfe7aa58c689e223de5110b0821ae3541268b9.zip
dev-ml/findlib: bump to 1.9.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/Manifest1
-rw-r--r--dev-ml/findlib/findlib-1.9.6.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-ml/findlib/Manifest b/dev-ml/findlib/Manifest
index 9d65940dc6c8..8011c819d969 100644
--- a/dev-ml/findlib/Manifest
+++ b/dev-ml/findlib/Manifest
@@ -1,3 +1,4 @@
DIST findlib-1.8.1.tar.gz 261544 BLAKE2B acfa9d4e0d118ebbc0dd7b03da1fe5eaa994e5fec13dc54e60ba42f643d93968469a1a43fe4f832433dca6c3902e8846616fcf460c748bf037fe16cb2f93a847 SHA512 0d8e1ff21217fcc6823aab3ac71282789691e4ae8c3607703d0393468247f93e2d084bd4e2a8795b523f2c7f193521d3aae4b8122c934ebf8b58c3185a5bc9c1
DIST findlib-1.9.3.tar.gz 264132 BLAKE2B 3779cb437c607d04ae6c7d8124270f36c9bd9baccce669f3785a9cd4a1a582302844019b69be14598ca807edecb26645d9d7b241e1d704c3f023ed039cad21f0 SHA512 27cc4ce141576bf477fb9d61a82ad65f55478740eed59fb43f43edb794140829fd2ff89ad27d8a890cfc336b54c073a06de05b31100fc7c01cacbd7d88e928ea
DIST findlib-1.9.5.tar.gz 271240 BLAKE2B 6f43281298a9e443f9b92bcb8996bc2a55c2be86df492540fe8b5fb3fbb199daf1daef68e14c981d153c885c443ebc4af9ffb957235dd14904b9d75ca387cfa2 SHA512 03514c618a16b02889db997c6c4789b3436b3ad7d974348d2c6dea53eb78898ab285ce5f10297c074bab4fd2c82931a8b7c5c113b994447a44abb30fca74c715
+DIST findlib-1.9.6.tar.gz 271246 BLAKE2B c9c98b9e92c0cf690e2c8794a1ed606c0288d49a016dfa08592c9f617be1020385f52bf37345a7cbcbc7f0fcb19750a6617036cbf90afef231eccdbc7132baf8 SHA512 cfaf1872d6ccda548f07d32cc6b90c3aafe136d2aa6539e03143702171ee0199add55269bba894c77115535dc46a5835901a5d7c75768999e72db503bfd83027
diff --git a/dev-ml/findlib/findlib-1.9.6.ebuild b/dev-ml/findlib/findlib-1.9.6.ebuild
new file mode 100644
index 000000000000..dd0efaf143a5
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.9.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt tk"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )"
+RDEPEND="${DEPEND}"
+
+QA_FLAGS_IGNORED='.*'
+
+src_prepare() {
+ default
+ export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+ export stublibs="${ocamlfind_destdir}/stublibs"
+}
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ if use doc; then
+ cd "${S}/doc" || die
+ dodoc QUICKSTART README DOCINFO
+ docinto html
+ dodoc -r ref-html guide-html
+ fi
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}