summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-09-08 07:29:05 +1200
committerKent Fredric <kentnl@gentoo.org>2018-09-08 07:31:01 +1200
commit24c80c90da487a546906752c9b63596fc6645a57 (patch)
tree0307919d66f4487c08dce3a000f99ecdab382f49 /dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild
parentnet-wireless/wireless-regdb: bump (diff)
downloadgentoo-24c80c90da487a546906752c9b63596fc6645a57.tar.gz
gentoo-24c80c90da487a546906752c9b63596fc6645a57.tar.bz2
gentoo-24c80c90da487a546906752c9b63596fc6645a57.zip
dev-perl/Authen-Radius: Bump to version 0.270.0
- export contrib/ via USE=examples Upstream: - Force FreeRADIUS dictionary format when BEGIN-VENDOR directive is found - Load included files using requested format - Add full support for octets type Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild')
-rw-r--r--dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild b/dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild
new file mode 100644
index 000000000000..e8f19084fc27
--- /dev/null
+++ b/dev-perl/Authen-Radius/Authen-Radius-0.270.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PORTAONE
+DIST_VERSION=0.27
+DIST_EXAMPLES=("contrib/*")
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Data-Dumper-1.0.0
+ >=dev-perl/Data-HexDump-0.20.0
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.120.0
+ >=dev-perl/Net-IP-1.260.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ dev-perl/Test-NoWarnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.26-cisco-dictionary.patch
+ "${FILESDIR}"/${PN}-0.26-no-install-db.patch
+)
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}