summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-20 04:43:06 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-20 11:26:17 +1200
commita128b4abffe4556f10b1e6cac4aaac5f57bee148 (patch)
treecc773b4e66f19d29f1f45d630321dc18524d70b2 /dev-perl/BerkeleyDB/BerkeleyDB-0.640.0.ebuild
parentgnome-base/gconf: Stabilize 3.2.6-r5 arm, #743517 (diff)
downloadgentoo-a128b4abffe4556f10b1e6cac4aaac5f57bee148.tar.gz
gentoo-a128b4abffe4556f10b1e6cac4aaac5f57bee148.tar.bz2
gentoo-a128b4abffe4556f10b1e6cac4aaac5f57bee148.zip
dev-perl/BerkeleyDB: Bump to version 0.640.0
Upstream: - Refresh ppport.h - Silence compiler warning from clang in code for calling "initial_value" Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/BerkeleyDB/BerkeleyDB-0.640.0.ebuild')
-rw-r--r--dev-perl/BerkeleyDB/BerkeleyDB-0.640.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-perl/BerkeleyDB/BerkeleyDB-0.640.0.ebuild b/dev-perl/BerkeleyDB/BerkeleyDB-0.640.0.ebuild
new file mode 100644
index 000000000000..6d77af849ed6
--- /dev/null
+++ b/dev-perl/BerkeleyDB/BerkeleyDB-0.640.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PMQS
+DIST_VERSION=0.64
+inherit perl-module db-use multilib
+
+DESCRIPTION="This module provides Berkeley DB interface for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Install DB_File if you want older support. BerkleyDB no longer
+# supports less than 2.0.
+
+RDEPEND="
+ >=sys-libs/db-2.0:=
+ <sys-libs/db-7:=
+"
+DEPEND="
+ >=sys-libs/db-2.0:=
+ <sys-libs/db-7:=
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker"
+
+PERL_RM_FILES=(
+ "t/meta-json.t"
+ "t/meta-yaml.t"
+ "t/pod.t"
+ "scan.pl"
+ "mkconsts.pl"
+)
+# parallel really broken
+DIST_TEST="do"
+src_prepare() {
+ local DB_SUPPORTED=(
+ 6 5 4 3 2
+ )
+ # on Gentoo/FreeBSD we cannot trust on the symlink /usr/include/db.h
+ # as for Gentoo/Linux, so we need to esplicitely declare the exact berkdb
+ # include path
+ local dbdir="$(db_includedir "${DB_SUPPORTED[@]}" )"
+ local dbname="$(db_libname "${DB_SUPPORTED[@]}" )"
+ einfo "DB Include Dir: ${dbdir}"
+ einfo "DB library: ${dbname}"
+
+ rm -f "${S}/config.in" || die "Can't remove packaged config.in"
+
+ printf "INCLUDE = %s\nLIB = %s\nDBNAME = -l%s\n" \
+ "${dbdir}" \
+ "${EPREFIX}/usr/$(get_libdir)" \
+ "${dbname}" > "${S}"/config.in || die "Can't write config.in"
+
+ perl-module_src_prepare
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}