summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-30 06:40:58 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-30 06:47:46 +1200
commite321c256d853d20d4d9b3123e39f5277c1e1a9c4 (patch)
treefd77c8d40450e598eb21f4ed1e7e57707b630b90 /dev-perl/Crypt-Blowfish
parentsys-apps/haveged: version bump to 1.9.13 (diff)
downloadgentoo-e321c256d853d20d4d9b3123e39f5277c1e1a9c4.tar.gz
gentoo-e321c256d853d20d4d9b3123e39f5277c1e1a9c4.tar.bz2
gentoo-e321c256d853d20d4d9b3123e39f5277c1e1a9c4.zip
dev-perl/Crypt-Blowfish: -r bump for EAPI7 & fixes
- EAPI7 - Remove some redundancy from DESCRIPTION - Fix LICENSE ( yes, its really the same licenses as Crypt-IDEA, no idea what license it is otherwise ) - Parallel tests - Localise the CFLAGS hackery, which proved to be useful, as the existing provision that *looked* like it would help, was tested to do nothing at all! - Add one test dep so CBC tests are runnable. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-Blowfish')
-rw-r--r--dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild b/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild
new file mode 100644
index 000000000000..abdc8041bf6b
--- /dev/null
+++ b/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DPARIS
+DIST_VERSION=2.14
+inherit perl-module
+
+DESCRIPTION="Perl Blowfish encryption module"
+
+LICENSE="Crypt-IDEA"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Crypt-CBC
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}