summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-19 23:37:09 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-20 02:23:01 +1300
commit1ee00efc8db7076eac51676b92df94ea005d4c04 (patch)
tree836fb385769b2c7a94c6c781532bdb47da523eec /dev-perl/Data-Validate-IP/Data-Validate-IP-0.270.0.ebuild
parentdev-libs/libgpg-error: New upstream version (diff)
downloadgentoo-1ee00efc8db7076eac51676b92df94ea005d4c04.tar.gz
gentoo-1ee00efc8db7076eac51676b92df94ea005d4c04.tar.bz2
gentoo-1ee00efc8db7076eac51676b92df94ea005d4c04.zip
dev-perl/Data-Validate-IP: Bump to version 0.270.0
Upstream: - Use optimised path through Socket.pm for is_*_ip routines where safe. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/Data-Validate-IP/Data-Validate-IP-0.270.0.ebuild')
-rw-r--r--dev-perl/Data-Validate-IP/Data-Validate-IP-0.270.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Data-Validate-IP/Data-Validate-IP-0.270.0.ebuild b/dev-perl/Data-Validate-IP/Data-Validate-IP-0.270.0.ebuild
new file mode 100644
index 000000000000..0b597fd40864
--- /dev/null
+++ b/dev-perl/Data-Validate-IP/Data-Validate-IP-0.270.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.27
+DIST_EXAMPLES=("bench/*")
+
+inherit perl-module
+
+DESCRIPTION="Lightweight IPv4 and IPv6 validation module"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Exporter
+ >=dev-perl/NetAddr-IP-4
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Requires
+ )
+"