summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-21 05:22:01 +0100
committerSam James <sam@gentoo.org>2023-06-21 05:27:58 +0100
commitba8d66a9e2898cf8e1cf4ffc124d6ab1057f76b2 (patch)
tree160c26feb41c05ebe400151571562012be9d6740 /dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.50.0.ebuild
parentdev-perl/Graph: add 0.972.600 (diff)
downloadgentoo-ba8d66a9e2898cf8e1cf4ffc124d6ab1057f76b2.tar.gz
gentoo-ba8d66a9e2898cf8e1cf4ffc124d6ab1057f76b2.tar.bz2
gentoo-ba8d66a9e2898cf8e1cf4ffc124d6ab1057f76b2.zip
dev-perl/Glib-Object-Introspection: add 0.50.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.50.0.ebuild')
-rw-r--r--dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.50.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.50.0.ebuild b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.50.0.ebuild
new file mode 100644
index 000000000000..63edf5e552ad
--- /dev/null
+++ b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.50.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=0.050
+inherit perl-module xdg-utils
+
+DESCRIPTION="Dynamically create Perl language bindings"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-perl/glib-perl-1.320.0
+ >=dev-libs/gobject-introspection-1.0
+ >=dev-libs/libffi-3.0.0:=
+ >=dev-libs/glib-2.0.0
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+"
+
+pkg_setup() {
+ # bug #599128
+ xdg_environment_reset
+}