summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-24 14:41:45 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-24 14:48:46 +1300
commit46f5df0ea03bcacb570f40ce2ac1d6c8ee0632a5 (patch)
tree402214d7df767d84c069682723fe510fe684acc2 /dev-perl/Gtk2-Ex-Simple-List
parentdev-perl/Gtk2-Ex-PrintDialog: Enable tests (diff)
downloadgentoo-46f5df0ea03bcacb570f40ce2ac1d6c8ee0632a5.tar.gz
gentoo-46f5df0ea03bcacb570f40ce2ac1d6c8ee0632a5.tar.bz2
gentoo-46f5df0ea03bcacb570f40ce2ac1d6c8ee0632a5.zip
dev-perl/Gtk2-Ex-Simple-List: Enable tests
- EAPI6 - Add USE=examples - Enable Tests (require X11) Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Gtk2-Ex-Simple-List')
-rw-r--r--dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r2.ebuild b/dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r2.ebuild
new file mode 100644
index 000000000000..ca999714796e
--- /dev/null
+++ b/dev-perl/Gtk2-Ex-Simple-List/Gtk2-Ex-Simple-List-0.500.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RMCFARLA
+DIST_VERSION=0.50
+DIST_SECTION=Gtk2-Perl-Ex
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module virtualx
+
+DESCRIPTION="A simple interface to Gtk2's complex MVC list widget"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )" # LGPL-2.1+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Gtk2-1.60.0
+ >=dev-perl/glib-perl-1.62.0
+"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ virtx perl-module_src_test
+}