summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/HTTP-Server-Simple
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/HTTP-Server-Simple')
-rw-r--r--dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.440.0-r1.ebuild24
-rw-r--r--dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.500.0.ebuild29
-rw-r--r--dev-perl/HTTP-Server-Simple/Manifest2
-rw-r--r--dev-perl/HTTP-Server-Simple/metadata.xml11
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.440.0-r1.ebuild b/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.440.0-r1.ebuild
new file mode 100644
index 000000000000..f4f25ccd9540
--- /dev/null
+++ b/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.440.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JESSE
+MODULE_VERSION=0.44
+inherit perl-module eutils
+
+DESCRIPTION="Lightweight HTTP Server"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )"
+
+SRC_TEST="do"
diff --git a/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.500.0.ebuild b/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.500.0.ebuild
new file mode 100644
index 000000000000..86e5de27f508
--- /dev/null
+++ b/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.500.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=FALCONE
+MODULE_VERSION=0.50
+inherit perl-module eutils
+
+DESCRIPTION="Lightweight HTTP Server"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/CGI
+ >=virtual/perl-Socket-1.940.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/HTTP-Server-Simple/Manifest b/dev-perl/HTTP-Server-Simple/Manifest
new file mode 100644
index 000000000000..a21cfb50dc37
--- /dev/null
+++ b/dev-perl/HTTP-Server-Simple/Manifest
@@ -0,0 +1,2 @@
+DIST HTTP-Server-Simple-0.44.tar.gz 33804 SHA256 cff4f882da63a9a71271e25d1dc9160e64e5dd1195ed0a63894609ada7bb7416 SHA512 d8a3abd636de5cbd1b169911d02bb207d071f3f4ec9056f7ae4892062ff57b61737e4dfd03db8629ae553368c97b40baa88d021f6e4f973900d94abcc780591e WHIRLPOOL c8d112eefddf60d69eb17b1779a8744507da9bb6e759247da6309ba12188dcdc76a99ab439b8079fd865d87f3c0b003550d62172b8e7fbde970c3ac5a9bda388
+DIST HTTP-Server-Simple-0.50.tar.gz 36290 SHA256 5bd8117f469f566f55ee12406a1f9e03942d6f64e42f6e7461051e738bc27602 SHA512 601486cfa0744db9a131d6720873ef1cf995000671cd373854c29fc9a0b482d4f7ace69b97a48019897675714320e718b87e87fdcfe084e88c762ea2249120a2 WHIRLPOOL 1590c52ff7daa1489fb0666184d5eaef770bb1ce3ebe089dc8417b80c75db3a6b3adcaf4d13d39db05ac6737cca129b3e075263b6b3967a7a60d6a57b18ca61b
diff --git a/dev-perl/HTTP-Server-Simple/metadata.xml b/dev-perl/HTTP-Server-Simple/metadata.xml
new file mode 100644
index 000000000000..2d082f1b7b0e
--- /dev/null
+++ b/dev-perl/HTTP-Server-Simple/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">HTTP-Server-Simple</remote-id>
+ <remote-id type="cpan-module">HTTP::Server::Simple</remote-id>
+ <remote-id type="cpan-module">HTTP::Server::Simple::CGI</remote-id>
+ <remote-id type="cpan-module">HTTP::Server::Simple::CGI::Environment</remote-id>
+ </upstream>
+</pkgmetadata>