summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-04 21:30:33 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-04 21:47:35 +1200
commitcfb070f032535e4bf19a5a651418af50d2d698a6 (patch)
treebd54b8aef75a820d897b24f62c042effae2908d5 /dev-perl/Mail-Box/Mail-Box-3.2.0.ebuild
parentnet-irc/bnc: ppc stable (bug 612976). (diff)
downloadgentoo-cfb070f032535e4bf19a5a651418af50d2d698a6.tar.gz
gentoo-cfb070f032535e4bf19a5a651418af50d2d698a6.tar.bz2
gentoo-cfb070f032535e4bf19a5a651418af50d2d698a6.zip
dev-perl/Mail-Box: Bump to version 3.2.0
Upstream: - Fix Win32 Test failures - Fix errors in global destruction of locker - Report POP3 instead of POP4 version in test Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Mail-Box/Mail-Box-3.2.0.ebuild')
-rw-r--r--dev-perl/Mail-Box/Mail-Box-3.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Mail-Box/Mail-Box-3.2.0.ebuild b/dev-perl/Mail-Box/Mail-Box-3.2.0.ebuild
new file mode 100644
index 000000000000..4b3b930639f2
--- /dev/null
+++ b/dev-perl/Mail-Box/Mail-Box-3.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARKOV
+DIST_VERSION=3.002
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Mail folder manager and MUA backend"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE="test"
+
+PDEPEND="
+ dev-perl/Mail-Box-IMAP4
+ dev-perl/Mail-Box-POP3
+"
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/TimeDate
+ >=dev-perl/Devel-GlobalDestruction-0.90.0
+ >=dev-perl/File-Remove-0.200.0
+ >=virtual/perl-File-Spec-0.700.0
+ dev-perl/IO-stringy
+ >=dev-perl/Mail-Message-3
+ >=dev-perl/Mail-Transport-3
+ >=dev-perl/Object-Realize-Later-0.190.0
+ >=virtual/perl-Scalar-List-Utils-1.130.0
+ >=virtual/perl-Test-Simple-0.470.0
+ !!<dev-perl/Mail-Box-3
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+DIST_TEST="do" # parallel tests fail