summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-20 05:40:16 +0100
committerSam James <sam@gentoo.org>2023-06-20 05:48:09 +0100
commit56e166d95b3a23488f7e13693bf4935be3529181 (patch)
tree27b3c57fb4b8fa335486ef160efd620ce2a43d19 /dev-perl/Math-BigInt-GMP
parentdev-ruby/strscan: drop 3.0.3, 3.0.4, 3.0.5 (diff)
downloadgentoo-56e166d95b3a23488f7e13693bf4935be3529181.tar.gz
gentoo-56e166d95b3a23488f7e13693bf4935be3529181.tar.bz2
gentoo-56e166d95b3a23488f7e13693bf4935be3529181.zip
dev-perl/Math-BigInt-GMP: add 1.601.200
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Math-BigInt-GMP')
-rw-r--r--dev-perl/Math-BigInt-GMP/Manifest1
-rw-r--r--dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.601.200.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-GMP/Manifest b/dev-perl/Math-BigInt-GMP/Manifest
index 305d0c8fb918..241f5e5e0603 100644
--- a/dev-perl/Math-BigInt-GMP/Manifest
+++ b/dev-perl/Math-BigInt-GMP/Manifest
@@ -1 +1,2 @@
DIST Math-BigInt-GMP-1.6007.tar.gz 2459995 BLAKE2B 971f4785b2068d02d80a6a50b4aecea4ef584c7b0e679ddfd3001518425361b36a646d1919fd06fc14a2b18733fdf2534e11aea666d4999b3003cbd946ae27d7 SHA512 cdeaeec1e450e95d761cefc63c5262c0b43cf5fc5865e62d0463e34821541c2b83d156979c1e7a8157c9747ccf5e3cefa80ac52489a7ce3186425bc27c176512
+DIST Math-BigInt-GMP-1.6012.tar.gz 2592463 BLAKE2B 5ff66bcabd76c756349fc84d7e5587d176e7b961e314268625ee6ab4921f774be8ebd0efef108636dc6bd36556a44f3442a8c89abbe19dc62fa36fcf6e7ed993 SHA512 cb8890b2f67f84a6328719f7a21173e8f6c6bbfe74a96d7d608d27c011d0b2390d6b9ea09e507cba56f885810f20bbc4aff3231f89312231d91d5c2e383893d6
diff --git a/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.601.200.ebuild b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.601.200.ebuild
new file mode 100644
index 000000000000..940cf1a8d1ff
--- /dev/null
+++ b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.601.200.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.6012
+inherit perl-module
+
+DESCRIPTION="Use the GMP library for Math::BigInt routines"
+
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=virtual/perl-Carp-1.220.0
+ >=virtual/perl-Math-BigInt-1.999.838
+ >=virtual/perl-XSLoader-0.20.0
+ >=dev-libs/gmp-4.0.0:0
+"
+DEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.580.0
+ test? ( >=virtual/perl-Test-Simple-0.820.0 )
+"
+
+src_test() {
+ perl_rm_files t/author-*.t t/00sig.t t/02pod.t t/03podcov.t
+ perl-module_src_test
+}