summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2023-03-12 14:06:41 -0400
committerSam James <sam@gentoo.org>2023-03-13 18:02:41 +0000
commitd5f4687340892579c9c1b3e0f7f82190d3ef76c1 (patch)
tree3989297638f8e4158721cf41838eae51f92a6f46 /dev-perl/Moo
parentdev-perl/Class-XSAccessor: rev-bump in prep for adding "~ia64 ~s390" (diff)
downloadgentoo-d5f4687340892579c9c1b3e0f7f82190d3ef76c1.tar.gz
gentoo-d5f4687340892579c9c1b3e0f7f82190d3ef76c1.tar.bz2
gentoo-d5f4687340892579c9c1b3e0f7f82190d3ef76c1.zip
dev-perl/Moo: Add missing Class-XSAccessor dep
Dropped ~ia64 ~s390 keywords, but will re-request them soon. Bug: https://bugs.gentoo.org/898358 Closes: https://github.com/gentoo/gentoo/pull/29853 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Moo')
-rw-r--r--dev-perl/Moo/Moo-2.5.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Moo/Moo-2.5.4-r1.ebuild b/dev-perl/Moo/Moo-2.5.4-r1.ebuild
new file mode 100644
index 000000000000..8f61768a4ea8
--- /dev/null
+++ b/dev-perl/Moo/Moo-2.5.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.005004
+inherit perl-module
+
+DESCRIPTION="Minimalist Object Orientation (with Moose compatiblity)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-Method-Modifiers-1.100.0
+ >=virtual/perl-Exporter-5.570.0
+ >=dev-perl/Role-Tiny-2.2.3
+ >=virtual/perl-Scalar-List-Utils-1.0.0
+ >=dev-perl/Sub-Quote-2.6.6
+ >=dev-perl/Class-XSAccessor-1.190.0-r2
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"