summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-06 02:42:38 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-08 01:07:41 +0200
commit0ba47a2296b080148a02af4162a8a002e00b2a98 (patch)
tree0500cfb2e0833b0332c3a1043790394dd631a208 /dev-perl/POE-Component-IKC
parentdev-perl/POE-Component-Client-DNS: Bump to version 0.54.0 (diff)
downloadgentoo-0ba47a2296b080148a02af4162a8a002e00b2a98.tar.gz
gentoo-0ba47a2296b080148a02af4162a8a002e00b2a98.tar.bz2
gentoo-0ba47a2296b080148a02af4162a8a002e00b2a98.zip
dev-perl/POE-Component-IKC: Bump to version 0.240.200
- EAPI6 - DESCRIPTION updated - tests cleaned up - more documentation installed - USE="examples" available Upstream: - Server/on_error added - Error monitor added - create_ikc_* now visibly deprecated - Timing bug avoided with filters - Ports no longer hard-coded Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/POE-Component-IKC')
-rw-r--r--dev-perl/POE-Component-IKC/Manifest1
-rw-r--r--dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild41
-rw-r--r--dev-perl/POE-Component-IKC/metadata.xml3
3 files changed, 43 insertions, 2 deletions
diff --git a/dev-perl/POE-Component-IKC/Manifest b/dev-perl/POE-Component-IKC/Manifest
index fe41d93c0eed..774bf1586e4e 100644
--- a/dev-perl/POE-Component-IKC/Manifest
+++ b/dev-perl/POE-Component-IKC/Manifest
@@ -1,2 +1,3 @@
DIST POE-Component-IKC-0.2303.tar.gz 69229 SHA256 c5371db5f544ce97a8bbccd5ed8e0ee91b513b1c2471851f83f30061fecb8d7a SHA512 b92e4a472dfdd4f8c30d40ef1fd2d091e5d5de08fba8d8b6d93c6461898b1830e141175453133a85d314c83e063c77ba03e79419f9e4f4ec582c9fa1ede1349c WHIRLPOOL 3d75ec8edd934719cb307c02254ac3657f87b8f3a70f6f4b012b86c51b083e3188afec2272ab581831fdecb92784ca7574ecd91e7309ecb68194c4057bdbcdce
DIST POE-Component-IKC-0.2305.tar.gz 69875 SHA256 5410204034e05f6340558a13963d3853dd4ea61d972e423edaa5c5f9d921d4e5 SHA512 b538ad4aa1ee62354951dfab42884ce09269e0e1e95fcf42fbb05ca6db160254b47843a11273da37c5821dd544a388d37114121bc1116bc048a2e85f91d16b8e WHIRLPOOL b47d3a4a6d215889722ace1b0a7b1e2dca7b77b610e0e49736d7b990053f3b673d1fcb63cbefcf3a404653430a97b44ea5781e1c1c4fd8f87989a6e210ea2669
+DIST POE-Component-IKC-0.2402.tar.gz 76246 SHA256 87b8696dce1cfa05a6054b8b7a65e733ae88f2ce52bb981743a250b579d0eab6 SHA512 4d335d91773eca62037036023a56b5b1de2d84a2d22121669457fa79981e6ee844bab657a174bab1ca7912ba50273f6bda98303eee17ff3a39ca98500b877cc0 WHIRLPOOL 67f0da7fe98df1eb90a2eab112273aebfa9397adccf9d4f57a9fba61f2e6900a8a7eff2702935dad6970a123b667426f3e1999cce7e0044dcbeecd4d2756b45e
diff --git a/dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild b/dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild
new file mode 100644
index 000000000000..7a173ed54957
--- /dev/null
+++ b/dev-perl/POE-Component-IKC/POE-Component-IKC-0.240.200.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=GWYN
+DIST_VERSION=0.2402
+inherit perl-module
+
+DESCRIPTION="Inter-Kernel Communication for POE"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test examples"
+
+RDEPEND="
+ >=dev-perl/Data-Dump-1.0.0
+ >=dev-perl/Devel-Size-0.770.0
+ >=dev-perl/POE-1.311.0
+ >=virtual/perl-Scalar-List-Utils-1.0.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.600.0 )
+"
+
+src_test() {
+ perl_rm_files t/01_pod.t t/02_pod_coverage.t
+ perl-module_src_test
+}
+
+src_install() {
+ perl-module_src_install
+ dodoc FUTUR ikc-architecture.txt
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc -r eg/*
+ fi
+}
diff --git a/dev-perl/POE-Component-IKC/metadata.xml b/dev-perl/POE-Component-IKC/metadata.xml
index 7189e00b3eee..9dc6399df62e 100644
--- a/dev-perl/POE-Component-IKC/metadata.xml
+++ b/dev-perl/POE-Component-IKC/metadata.xml
@@ -16,10 +16,9 @@
<remote-id type="cpan-module">POE::Component::IKC::Protocol</remote-id>
<remote-id type="cpan-module">POE::Component::IKC::Proxy</remote-id>
<remote-id type="cpan-module">POE::Component::IKC::Responder</remote-id>
- <remote-id type="cpan-module">POE::Component::IKC::Responder::Object</remote-id>
- <remote-id type="cpan-module">POE::Component::IKC::Responder::Thunk</remote-id>
<remote-id type="cpan-module">POE::Component::IKC::Server</remote-id>
<remote-id type="cpan-module">POE::Component::IKC::Specifier</remote-id>
<remote-id type="cpan-module">POE::Component::IKC::Timing</remote-id>
+ <remote-id type="cpan-module">POE::Component::IKC::Util</remote-id>
</upstream>
</pkgmetadata>