summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-11 13:08:36 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-11 13:12:56 +1200
commit715f65a5b423188744ad302742e7ee504024ad4a (patch)
tree86a781d2bb12e9d6cb55823ad71003aff89a108f /dev-perl/SQL-Abstract/SQL-Abstract-1.840.0.ebuild
parentsys-kernel/hardened-sources: version bump to 4.9.21 (diff)
downloadgentoo-715f65a5b423188744ad302742e7ee504024ad4a.tar.gz
gentoo-715f65a5b423188744ad302742e7ee504024ad4a.tar.bz2
gentoo-715f65a5b423188744ad302742e7ee504024ad4a.zip
dev-perl/SQL-Abstract: Bump to version 1.840.0
- EAPI6 - Add USE=examples - Parallel Tests Upstream: - Support for DELETE .. RETURNING - Add Sub::Quote explicit dep - Fix order clauses with bind parameters in ->where - fix ->insert($table,\@values) with >26 values - ::Tree now knows that ILIKE and REGEXP are binary ops Bug: https://bugs.gentoo.org/615224 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/SQL-Abstract/SQL-Abstract-1.840.0.ebuild')
-rw-r--r--dev-perl/SQL-Abstract/SQL-Abstract-1.840.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/SQL-Abstract/SQL-Abstract-1.840.0.ebuild b/dev-perl/SQL-Abstract/SQL-Abstract-1.840.0.ebuild
new file mode 100644
index 000000000000..ebb361584178
--- /dev/null
+++ b/dev-perl/SQL-Abstract/SQL-Abstract-1.840.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ILMARI
+DIST_VERSION=1.84
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Generate SQL from Perl data structures"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Exporter-5.570.0
+ >=dev-perl/Hash-Merge-0.120.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/MRO-Compat-0.120.0
+ >=dev-perl/Moo-2.0.1
+ >=dev-perl/Sub-Quote-2.0.1
+ >=virtual/perl-Text-Balanced-2.0.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Storable
+ >=dev-perl/Test-Deep-0.101.0
+ >=dev-perl/Test-Exception-0.310.0
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Warn
+ )
+"