summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-04-29 23:13:44 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-04-29 23:14:52 -0700
commitc2bce6bb75b6f51f9481fe5a28ab3cc39fc682e6 (patch)
tree360e14315083403f552706bdfee0e2f4e836d088 /dev-perl/WWW-Curl
parentpython-utils-r1.eclass: Restore old CPython version reqs (diff)
downloadgentoo-c2bce6bb75b6f51f9481fe5a28ab3cc39fc682e6.tar.gz
gentoo-c2bce6bb75b6f51f9481fe5a28ab3cc39fc682e6.tar.bz2
gentoo-c2bce6bb75b6f51f9481fe5a28ab3cc39fc682e6.zip
dev-perl/WWW-Curl: compile-fix for newer net-misc/curl
Reference: https://rt.cpan.org/Public/Bug/Display.html?id=132197 Closes: https://bugs.gentoo.org/713008 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-perl/WWW-Curl')
-rw-r--r--dev-perl/WWW-Curl/WWW-Curl-4.170.0-r1.ebuild1
-rw-r--r--dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT132197.patch41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/WWW-Curl/WWW-Curl-4.170.0-r1.ebuild b/dev-perl/WWW-Curl/WWW-Curl-4.170.0-r1.ebuild
index d9eb8c504aba..55cab9448db5 100644
--- a/dev-perl/WWW-Curl/WWW-Curl-4.170.0-r1.ebuild
+++ b/dev-perl/WWW-Curl/WWW-Curl-4.170.0-r1.ebuild
@@ -23,5 +23,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.17-networktests.patch
"${FILESDIR}"/${PN}-4.17-RT117793.patch
"${FILESDIR}"/${PN}-4.17-RT130591.patch
+ "${FILESDIR}"/${PN}-4.17-RT132197.patch
)
PERL_RM_FILES=("t/meta.t" "t/pod-coverage.t" "t/pod.t")
diff --git a/dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT132197.patch b/dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT132197.patch
new file mode 100644
index 000000000000..77a97dd71862
--- /dev/null
+++ b/dev-perl/WWW-Curl/files/WWW-Curl-4.17-RT132197.patch
@@ -0,0 +1,41 @@
+From ee910449bf764d9f582e612c9b8b61b1d18e3a7c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
+Date: Thu, 9 Apr 2020 14:31:05 +0200
+Subject: [PATCH] Adapt to changes in cURL 7.69.0
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+WIN32 macro was removed (1adebe7886ddf20b0733bf9ccbae4ed4866dcfb6) and
+then added under a CURL_WIN32 name
+(8bd863f97b6c79f561bc063e634cecdf4badf776). This a C preprocessor
+macro for driving the C compiler, not a cURL option. Thus this fix
+ignores it.
+
+CURLOPT(na,t,nu) macro was added
+(920deff8618a19ae80bd319851722f1b05751f69) as replacement for CINIT()
+macro. It's not a cURL option. This fix also ignores it.
+
+CPAN RT#132197
+
+Signed-off-by: Petr Písař <ppisar@redhat.com>
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index ad2bd3d..b9e6a46 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -127,7 +127,7 @@ if (!defined($curl_h)) {
+ close H;
+
+ for my $e (sort @syms) {
+- if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|^CURL_DID_MEMORY_FUNC_TYPEDEFS\z|_LAST\z|_LASTENTRY\z|^CURLINC_)/) {
++ if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|^CURL_DID_MEMORY_FUNC_TYPEDEFS\z|_LAST\z|_LASTENTRY\z|^CURLINC_|^CURL_WIN32\z|^CURLOPT\z)/) {
+ next;
+ }
+ my ($group) = $e =~ m/^([^_]+_)/;
+--
+2.21.1
+