summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-21 13:57:47 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-21 13:58:25 +1300
commitdae187f9846017f28fbbd0047db520cad0b4daa8 (patch)
tree79de718a6c9eee892aa4afb1f4a8f3d5da061920 /dev-perl/Wx
parentdev-perl/Alien-wxWidgets: Fix use of wxwidgets eclass (diff)
downloadgentoo-dae187f9846017f28fbbd0047db520cad0b4daa8.tar.gz
gentoo-dae187f9846017f28fbbd0047db520cad0b4daa8.tar.bz2
gentoo-dae187f9846017f28fbbd0047db520cad0b4daa8.zip
dev-perl/Wx: Force newer Alien-wxWidgets to avoid wxgtk build issues
Older EAPI6 versions of Alien-wxWidgets could build against versions of wxGTK that eventually lead to dev-perl/Wx failing to compile. Also avoids using deprecated API of wxwidgets.eclass Bug: https://bugs.gentoo.org/615246 Closes: https://bugs.gentoo.org/627180 Closes: https://bugs.gentoo.org/623042 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Wx')
-rw-r--r--dev-perl/Wx/Wx-0.993.200-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Wx/Wx-0.993.200-r1.ebuild b/dev-perl/Wx/Wx-0.993.200-r1.ebuild
new file mode 100644
index 000000000000..b1d9866a7aed
--- /dev/null
+++ b/dev-perl/Wx/Wx-0.993.200-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+DIST_AUTHOR=MDOOTSON
+DIST_VERSION=0.9932
+DIST_EXAMPLES=("samples/*")
+inherit wxwidgets virtualx perl-module
+
+DESCRIPTION="Perl bindings for wxGTK"
+HOMEPAGE="http://wxperl.sourceforge.net/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Alien-wxWidgets-0.690.0-r1
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=virtual/perl-File-Spec-0.820.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ >=virtual/perl-ExtUtils-ParseXS-3.150.0
+ >=dev-perl/ExtUtils-XSpp-0.160.200
+ >=virtual/perl-if-0.30.0
+ test? (
+ >=virtual/perl-Test-Harness-2.260.0
+ >=virtual/perl-Test-Simple-0.430.0
+ )
+"
+
+src_prepare() {
+ setup-wxwidgets
+ perl-module_src_prepare
+}
+
+src_test() {
+ # the webview/t/03_threads.t test tends to hang or crash in weird
+ # ways depending on local configuration. eg, backtraces involving
+ # all of webkit-gtk, kpartsplugin and kdelibs...
+ perl_rm_files t/12_pod.t ext/webview/t/03_threads.t
+ virtx perl-module_src_test
+}