summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-06 06:31:11 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-06 06:31:11 +1200
commit0e3a19454967d362ae73a40ed0ba176a3a3da15c (patch)
treef82ca4435834268e329bb78854954dd091fcd57d /dev-perl
parentdev-perl/CDB_File: -r bump for CFLAGS love (diff)
downloadgentoo-0e3a19454967d362ae73a40ed0ba176a3a3da15c.tar.gz
gentoo-0e3a19454967d362ae73a40ed0ba176a3a3da15c.tar.bz2
gentoo-0e3a19454967d362ae73a40ed0ba176a3a3da15c.zip
dev-perl/Class-C3-XS: -r bump for CFLAGS love
- Ensure CFLAGS passed to make/compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Class-C3-XS/Class-C3-XS-0.150.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Class-C3-XS/Class-C3-XS-0.150.0-r1.ebuild b/dev-perl/Class-C3-XS/Class-C3-XS-0.150.0-r1.ebuild
new file mode 100644
index 000000000000..c59e0624cfc6
--- /dev/null
+++ b/dev-perl/Class-C3-XS/Class-C3-XS-0.150.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.15
+inherit perl-module
+
+DESCRIPTION="XS speedups for Class::C3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}