summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-12-06 10:50:18 -0500
committerBrian Evans <grknight@gentoo.org>2018-12-06 10:50:18 -0500
commit8882c2e551259d9e41e09f7a6cb68b36bdc8462c (patch)
tree192bc669b3178d51639065ffc5fda899a540a249 /dev-php/PEAR-DB/PEAR-DB-1.9.3.ebuild
parentdev-db/freetds: Drop old (diff)
downloadgentoo-8882c2e551259d9e41e09f7a6cb68b36bdc8462c.tar.gz
gentoo-8882c2e551259d9e41e09f7a6cb68b36bdc8462c.tar.bz2
gentoo-8882c2e551259d9e41e09f7a6cb68b36bdc8462c.zip
dev-php/PEAR-DB: Version bump for 1.9.3
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-DB/PEAR-DB-1.9.3.ebuild')
-rw-r--r--dev-php/PEAR-DB/PEAR-DB-1.9.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/PEAR-DB/PEAR-DB-1.9.3.ebuild b/dev-php/PEAR-DB/PEAR-DB-1.9.3.ebuild
new file mode 100644
index 000000000000..b7d376017594
--- /dev/null
+++ b/dev-php/PEAR-DB/PEAR-DB-1.9.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="Database abstraction layer for PHP"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="test"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+DOCS=( doc/TESTERS doc/IDEAS doc/MAINTAINERS doc/STATUS )
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR, and also
+ # a working version of the cli SAPI eselected.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}