summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-17 21:45:41 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-17 22:01:27 +0100
commit6feee8d55100c335af149fa0959c24f33596f5f0 (patch)
treeab9c063de25dd56affa49236bf6265d17fa8daf8 /dev-php/PEAR-Mail_Mime
parentdev-php/jsonlint: bump to v1.7.2 (diff)
downloadgentoo-6feee8d55100c335af149fa0959c24f33596f5f0.tar.gz
gentoo-6feee8d55100c335af149fa0959c24f33596f5f0.tar.bz2
gentoo-6feee8d55100c335af149fa0959c24f33596f5f0.zip
dev-php/PEAR-Mail_Mime: bump to v1.10.4
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Mail_Mime')
-rw-r--r--dev-php/PEAR-Mail_Mime/Manifest1
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-Mail_Mime/Manifest b/dev-php/PEAR-Mail_Mime/Manifest
index 6fa8a9975bbf..ba4b71d3e6e3 100644
--- a/dev-php/PEAR-Mail_Mime/Manifest
+++ b/dev-php/PEAR-Mail_Mime/Manifest
@@ -1 +1,2 @@
DIST Mail_Mime-1.10.2.tgz 36501 BLAKE2B 59e900b99061e84d307eb46d295f843404ae06b01936cec4ed610c298b6f7e8fcee15098fa6d935696122311eae2dbf733611410b2249f2535673a3031011fa3 SHA512 4e3b2a2adc58d8b4f16f56509c9f22638dc37aedf1bec60871706390198198be6ed6dccae8c250eb33de3a441aeb122097ffaddbc49191745f0f09693ec6612b
+DIST Mail_Mime-1.10.4.tgz 36909 BLAKE2B 101d050d96b717ad970a6f8c170ba8ea7d94252274f0b006a266a5ef4ac9d49fb350d3bf120ce645e5a54af1f0ad0ab664c828abfa8a4a96170e7204c73dfd82 SHA512 6e58e1078292cf43605313e2402b60deb97be0b56c8eb5dbbb501cf92ca836ca4bdbc9e1ab878c89f8e59941962a91b73dd917c8e678f0944f271e5537f065e5
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild
new file mode 100644
index 000000000000..e23d097da656
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit php-pear-r2
+
+DESCRIPTION="Create and manipulate mime messages with PHP"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}