summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-19 10:47:56 -0400
committerBrian Evans <grknight@gentoo.org>2017-03-19 10:47:56 -0400
commitc27e58bfb92075bda68ccf8691204bea7ccd2c57 (patch)
treedc8b50f46944eebc0ce97caf45f23cdbb149a016 /dev-php/PEAR-PEAR_PackageFileManager_Plugins
parentdev-php/PEAR-PEAR_PackageFileManager2: Revbump to fix WORKDIR wrt bug 613122 (diff)
downloadgentoo-c27e58bfb92075bda68ccf8691204bea7ccd2c57.tar.gz
gentoo-c27e58bfb92075bda68ccf8691204bea7ccd2c57.tar.bz2
gentoo-c27e58bfb92075bda68ccf8691204bea7ccd2c57.zip
dev-php/PEAR-PEAR_PackageFileManager_Plugins: Revbump to fix WORKDIR wrt bug 613122
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-php/PEAR-PEAR_PackageFileManager_Plugins')
-rw-r--r--dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4-r1.ebuild16
-rw-r--r--dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild39
2 files changed, 16 insertions, 39 deletions
diff --git a/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4-r1.ebuild b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..021965393c4f
--- /dev/null
+++ b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Various methods to check files to update an existing package.xml file"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-php/PEAR-PEAR-1.10.1
+ >=dev-php/PEAR-XML_Serializer-0.19.0
+ >=dev-lang/php-5.3:*[xml,simplexml]"
diff --git a/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild b/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild
deleted file mode 100644
index 2d32e7a57fd8..000000000000
--- a/dev-php/PEAR-PEAR_PackageFileManager_Plugins/PEAR-PEAR_PackageFileManager_Plugins-1.0.4.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-HOMEPAGE="http://pear.php.net/package/${MY_PN}"
-SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
-DESCRIPTION="Various methods to check files to update an existing package.xml file"
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-php/PEAR-PEAR-1.10.1
- >=dev-php/PEAR-XML_Serializer-0.19.0
- >=dev-lang/php-5.3:*[xml,simplexml]"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- insinto /usr/share/php
- doins -r PEAR
-}
-
-pkg_postinst() {
- # Register the package from the package.xml file
- # Operation is not critical so die is not required
- if [[ -f "${WORKDIR}/package.xml" ]] ; then
- "${EROOT}usr/bin/peardev" install -nrO --force "${WORKDIR}/package.xml" 2> /dev/null
- fi
-}
-
-pkg_postrm() {
- # Uninstall known dependency
- "${EROOT}usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
-}