summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/onphp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/onphp')
-rw-r--r--dev-php/onphp/Manifest2
-rw-r--r--dev-php/onphp/metadata.xml5
-rw-r--r--dev-php/onphp/onphp-1.0.10.ebuild30
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-php/onphp/Manifest b/dev-php/onphp/Manifest
new file mode 100644
index 000000000000..e6434985cc80
--- /dev/null
+++ b/dev-php/onphp/Manifest
@@ -0,0 +1,2 @@
+DIST onphp-1.0.10.tar.bz2 298669 SHA256 f655f84dc0a314c0972b2bb4afe357bc928153ac0e6bf45035d54cd4401787fc SHA512 f8a44325fcefd2162bb08ae494396f4c8e91f183c61c5234f1e29807fa3eb9320bb2f081e99ca1e6bf588b1bd77d5a88b9f2d98f20c1907cffe87c28c30dd1cc WHIRLPOOL 7fbea00b492153f03bda84138c468f198edce542a7db8fa1c719660ffcbda3dfc41f5b9bd30749e351f8f24f6f3552cb41e191a5bba43da89ca68aaff28db44c
+DIST onphp-api-1.0.10.tar.bz2 35427359 SHA256 cdc0542a376da9fe099bf205ff990ca229554b5a6572c97381060afc6fb958ab SHA512 4acdb9c804fd2bb7cfbefd22efcb0956972b2b94679627352169948a0fb23f97deca2f7aa77690cf3a5b6614299c0d9515802d9321cfa680e9a4a06d0533d4e5 WHIRLPOOL be73d5dc21e7113e4e721c876c3420375bd3e82ebc57266548d1d654a437561b1a93650e4d3d22764715d06245f5cf7240df6ce7a6acc58d35e39aab66e0807b
diff --git a/dev-php/onphp/metadata.xml b/dev-php/onphp/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/onphp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/onphp/onphp-1.0.10.ebuild b/dev-php/onphp/onphp-1.0.10.ebuild
new file mode 100644
index 000000000000..8da58d5a2e18
--- /dev/null
+++ b/dev-php/onphp/onphp-1.0.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework"
+HOMEPAGE="http://onphp.org/"
+SRC_URI="http://onphp.org/download/${P}.tar.bz2
+ doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="dev-lang/php"
+
+src_install() {
+ dodoc `find doc -maxdepth 1 -type f -print`
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
+ fi
+
+ insinto "/usr/share/php/${PN}"
+ doins global.inc.php.tpl
+ doins -r core main meta
+}