summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-mysqlnd_ms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-mysqlnd_ms')
-rw-r--r--dev-php/pecl-mysqlnd_ms/Manifest1
-rw-r--r--dev-php/pecl-mysqlnd_ms/metadata.xml8
-rw-r--r--dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.5.2-r1.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/pecl-mysqlnd_ms/Manifest b/dev-php/pecl-mysqlnd_ms/Manifest
new file mode 100644
index 000000000000..63f3cd44d205
--- /dev/null
+++ b/dev-php/pecl-mysqlnd_ms/Manifest
@@ -0,0 +1 @@
+DIST mysqlnd_ms-1.5.2.tgz 385916 SHA256 22b9ba1afb36b3df11c1051c813bc07889c815d1d9993bb07ffda182665b472f SHA512 5ab888d683384e9d2b33df8d057cf438411b6506759a80b8bad79608bb4029abf77535ffc8472e8e478d5d456c2260b5dd4bc68396180a9ebfed45f90bdc8d7d WHIRLPOOL 6d3d8786c74d4dfac384af3ea9f0cd8664e99aeaa766806ef8319c955135ab57092c2db27ef615def5574ab05c5a8a4e8e1f7bff9888a4cd3b3fc660c623fbe0
diff --git a/dev-php/pecl-mysqlnd_ms/metadata.xml b/dev-php/pecl-mysqlnd_ms/metadata.xml
new file mode 100644
index 000000000000..f891503ca635
--- /dev/null
+++ b/dev-php/pecl-mysqlnd_ms/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <maintainer>
+ <email>olemarkus@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.5.2-r1.ebuild b/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..28ab4838571c
--- /dev/null
+++ b/dev-php/pecl-mysqlnd_ms/pecl-mysqlnd_ms-1.5.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="mysqlnd_ms"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+# php5-6 fails to build
+USE_PHP="php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="A replication and load balancing plugin for the mysqlnd library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+# Specifying targets due to USE flag transition
+DEPEND="
+ php_targets_php5-4? ( dev-lang/php:5.4[mysqlnd] )
+ php_targets_php5-5? ( || (
+ dev-lang/php:5.5[-libmysqlclient,mysql]
+ dev-lang/php:5.5[-libmysqlclient,mysqli]
+ )
+ )
+"
+RDEPEND="${DEPEND}"