summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-12-21 09:37:22 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-23 00:08:07 +0100
commita00d1bd08634b0d1a02ed785dab78b01027c9708 (patch)
tree6e621a6d8fec2ff2a95e5e2e8fb918827edce121 /dev-php/symfony-console/symfony-console-2.8.48.ebuild
parentdev-php/spdx-licenses: bump to 1.5.0 (diff)
downloadgentoo-a00d1bd08634b0d1a02ed785dab78b01027c9708.tar.gz
gentoo-a00d1bd08634b0d1a02ed785dab78b01027c9708.tar.bz2
gentoo-a00d1bd08634b0d1a02ed785dab78b01027c9708.zip
dev-php/symfony-console: bump to 2.8.48
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/symfony-console/symfony-console-2.8.48.ebuild')
-rw-r--r--dev-php/symfony-console/symfony-console-2.8.48.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/symfony-console/symfony-console-2.8.48.ebuild b/dev-php/symfony-console/symfony-console-2.8.48.ebuild
new file mode 100644
index 000000000000..e3887444f9e9
--- /dev/null
+++ b/dev-php/symfony-console/symfony-console-2.8.48.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Subtree split of the Symfony Console Component"
+HOMEPAGE="https://github.com/symfony/console"
+SRC_URI="https://github.com/symfony/console/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2
+ >=dev-php/symfony-event-dispatcher-2.1.0
+ >=dev-php/symfony-process-2.8.12"
+
+S="${WORKDIR}/console-${PV}"
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/Console"
+ doins -r . "${FILESDIR}"/autoload.php
+ dodoc README.md
+}