summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-11 20:38:04 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-11 21:43:40 +0300
commit95a2e3345b60599ae6381e84839d5131dbb2ab92 (patch)
tree301afcb5827e74af47583a73dcbf43c5b3f7cead /dev-php
parentdev-php/PEAR-Text_Wiki_BBCode: treeclean (diff)
downloadgentoo-95a2e3345b60599ae6381e84839d5131dbb2ab92.tar.gz
gentoo-95a2e3345b60599ae6381e84839d5131dbb2ab92.tar.bz2
gentoo-95a2e3345b60599ae6381e84839d5131dbb2ab92.zip
dev-php/PEAR-Text_Wiki_Mediawiki: treeclean
Bug: https://bugs.gentoo.org/933998 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/Manifest1
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild30
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch36
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/metadata.xml8
4 files changed, 0 insertions, 75 deletions
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest b/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest
deleted file mode 100644
index 0fc75a5a74bf..000000000000
--- a/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Text_Wiki_Mediawiki-0.2.0_p20140604.tar.gz 22941 BLAKE2B d208b4df7e01a2b28e44ada0226be0f183fe6ffefe742f9b6cb4f2b366f915ae46d950d574a8357cbec273f41792f17a639f5512613628ee60ed137d909be9dd SHA512 aef4d18a4a0b9f41dc4bad701a90a2e7d674851b63206db9dd87cf87d6705991c8221e41cdbb8d2572a950520ce87db96105a009e4189e48b8e7f5df0f460ee5
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild b/dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild
deleted file mode 100644
index 25c8a0342475..000000000000
--- a/dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit php-pear-r2 vcs-snapshot
-
-SRC_URI="https://github.com/pear/Text_Wiki_Mediawiki/archive/11a902741d3f8cc6010fb97b825d66345143e4dc.tar.gz -> ${PEAR_P}.tar.gz"
-DESCRIPTION="Mediawiki parser for Text_Wiki"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND=">=dev-php/PEAR-Text_Wiki-1.2.2_p20170904"
-DEPEND="test? (
- ${RDEPEND}
- <dev-php/phpunit-6
- )"
-PATCHES=( "${FILESDIR}/0.2.0-constructor.patch" )
-
-src_test() {
- phpunit tests/Text_Wiki_Parse_Mediawiki_Test.php || die
-}
-
-src_install() {
- php-pear-r2_src_install
- insinto /usr/share/php/.packagexml
- newins package.xml "${PEAR_P}.xml"
-}
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch b/dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch
deleted file mode 100644
index edd8e3572de0..000000000000
--- a/dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -aurN a/Text/Wiki/Mediawiki.php b/Text/Wiki/Mediawiki.php
---- a/Text/Wiki/Mediawiki.php 2014-06-04 23:24:45.000000000 -0400
-+++ b/Text/Wiki/Mediawiki.php 2018-02-14 13:36:18.777893414 -0500
-@@ -87,7 +87,7 @@
- * @param array $rules The set of rules to load for this object.
- */
- function __construct($rules = null) {
-- parent::Text_Wiki($rules);
-+ parent::__construct($rules);
- $this->addPath('parse', $this->fixPath(dirname(__FILE__)).'Parse/Mediawiki');
- }
- }
-diff -aurN a/Text/Wiki/Parse/Mediawiki/Url.php b/Text/Wiki/Parse/Mediawiki/Url.php
---- a/Text/Wiki/Parse/Mediawiki/Url.php 2014-06-04 23:24:45.000000000 -0400
-+++ b/Text/Wiki/Parse/Mediawiki/Url.php 2018-02-14 13:40:21.974024459 -0500
-@@ -87,7 +87,7 @@
- */
- function __construct(&$obj)
- {
-- parent::Text_Wiki_Parse($obj);
-+ parent::__construct($obj);
-
- // convert the list of recognized schemes to a regex-safe string,
- // where the pattern delim is a slash
-diff -aurN a/Text/Wiki/Parse/Mediawiki/Wikilink.php b/Text/Wiki/Parse/Mediawiki/Wikilink.php
---- a/Text/Wiki/Parse/Mediawiki/Wikilink.php 2014-06-04 23:24:45.000000000 -0400
-+++ b/Text/Wiki/Parse/Mediawiki/Wikilink.php 2018-02-14 13:40:46.030542359 -0500
-@@ -99,7 +99,7 @@
- function __construct(&$obj)
- {
- $default = $this->conf;
-- parent::Text_Wiki_Parse($obj);
-+ parent::__construct($obj);
-
- // override config options for image if specified
- if (in_array('Image', $this->wiki->disable)) {
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/metadata.xml b/dev-php/PEAR-Text_Wiki_Mediawiki/metadata.xml
deleted file mode 100644
index 77793b997e9e..000000000000
--- a/dev-php/PEAR-Text_Wiki_Mediawiki/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
-</maintainer>
-</pkgmetadata>