summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-23 04:37:43 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-23 05:22:14 +0100
commit5174e84ba33eadc42f404dca7922aad6a0943ba4 (patch)
tree964d4f3c92aa7ffaf04e47802cd2d0e5248de090 /dev-python/Faker
parentdev-python/hypothesis: Bump to 6.96.3 (diff)
downloadgentoo-5174e84ba33eadc42f404dca7922aad6a0943ba4.tar.gz
gentoo-5174e84ba33eadc42f404dca7922aad6a0943ba4.tar.bz2
gentoo-5174e84ba33eadc42f404dca7922aad6a0943ba4.zip
dev-python/Faker: Bump to 22.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-22.5.0.ebuild40
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-22.5.0.ebuild b/dev-python/Faker/Faker-22.5.0.ebuild
new file mode 100644
index 000000000000..4a85c701f3c8
--- /dev/null
+++ b/dev-python/Faker/Faker-22.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 666f805e8810..b964a3c784b0 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,3 +1,4 @@
DIST Faker-22.0.0.tar.gz 1702044 BLAKE2B 17bb5fe42f3d754358a1cf21a23a6917571bdeaff5967b94b3dcc62e08b274f9647ab19b9fa252ccf0f6f821da93ad474c2dddce3c07813048cd910b96d6c68a SHA512 b1539ca7b37d14dcbb06a4dbc198dfacaf4f0d7189f8e8a8986b42ac44780fa1b78c5b02d6f7a289c68a190a83e439f76a92587ee582105c4001246a39d046ce
DIST Faker-22.2.0.tar.gz 1702497 BLAKE2B ed5d215399d168b79661a5db5a0b7c9a8321f5fdba30041eb6640cc9e6700d838aa7291060b022cc76a44ce2dd3c28eabbe30be35e4b0311edf4c09f4c523042 SHA512 c9a97a29885d73cbd9920938574e7615be43243a4d524391a4e51a1dcf8ca3188a9606094e715773fbd81740145813b1920ac35e99e49dc932d95045e14fa546
DIST Faker-22.4.0.tar.gz 1702616 BLAKE2B 1a50724c0c8faaf4b2e72d3b23f242be19862133c79a1d49b8919512355ec84d565768b1c0868f287708880a13e833bab4dc911a9f4df53d9a225fa3ea75e00c SHA512 a8531b839c46c0403c37d1f5d58b026a2f8bf9ef66c4ce6302673dc7988250d51d069740bf783abf5b610afc2d01e23aa769c7d32ee03927befb13a610adc586
+DIST Faker-22.5.0.tar.gz 1703089 BLAKE2B 8c03883f60fa7ab39cc4dee6f73907b34d8b8a7a2f2f55f3842e9807625ff92dff5e3268f4f48048483ec707f4e0c0d4fb4d4c8b6a52f86ec204b8dbd4cad9b9 SHA512 b3ed913304cca9768b79685e449f49c56ad94274e213d77f64afe713b765e128dd5ef8d02222a3519c87ae5d4f567c64e2f8734972c95072f7a23119cc76cf09