summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 09:15:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-26 11:01:27 +0200
commit5c2e93bd1fa2562face98f7aca20b1b605d1b914 (patch)
treebf4a8cb5b90fd7e8f7c539ebe365561e815d15c3 /dev-python/Faker
parentdev-python/trimesh: Bump to 3.12.4 (diff)
downloadgentoo-5c2e93bd1fa2562face98f7aca20b1b605d1b914.tar.gz
gentoo-5c2e93bd1fa2562face98f7aca20b1b605d1b914.tar.bz2
gentoo-5c2e93bd1fa2562face98f7aca20b1b605d1b914.zip
dev-python/Faker: Bump to 13.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-13.12.0.ebuild34
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-13.12.0.ebuild b/dev-python/Faker/Faker-13.12.0.ebuild
new file mode 100644
index 000000000000..e6e86886aeab
--- /dev/null
+++ b/dev-python/Faker/Faker-13.12.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 92cf4960cb3c..7eda005b1bd6 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1,2 @@
DIST Faker-13.11.1.tar.gz 1501239 BLAKE2B 1ccf33e7a054d33921696ea917670fc0ff88c0b805700b32d9d4e5ed3b12d6e52ea164f762600315370eed06415e70923002b99f0c32fa9cd40cdeb437e338c0 SHA512 291517669143119099ac6bcc69a08091fb156728c465198079f764996849d8416ccaf169e1cf0d0dd02d99b2090494084dad7fdef9dfd2702411701bf71f54b5
+DIST Faker-13.12.0.tar.gz 1528234 BLAKE2B ca85e172d75f009802486fd5299581c0bd08f273f049df12b44159fb0c79d6b267579172da3c25f5aebaa0b897ea1e1067fe8e6a2527b0ccbf1e60de0257289c SHA512 9883e1a82b8d00ad83a31c71929ebb8f13e31bb34ada29772ab0bd8e9ac5e59ea44cf1a876e8c58a519814207fbc5ed950fdce7f7c259e5ca897e23662cd6511