summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 23:02:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:55 -0500
commit839daea989601604af289e75d536f3f88a9ab7f9 (patch)
tree5e154931f562b0c1ba23cdc4905ef95a18211627 /dev-python/WSME/WSME-0.9.3.ebuild
parentdev-python/taskflow: 3.4.0 bump (diff)
downloadgentoo-839daea989601604af289e75d536f3f88a9ab7f9.tar.gz
gentoo-839daea989601604af289e75d536f3f88a9ab7f9.tar.bz2
gentoo-839daea989601604af289e75d536f3f88a9ab7f9.zip
dev-python/WSME: 0.9.3 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/WSME/WSME-0.9.3.ebuild')
-rw-r--r--dev-python/WSME/WSME-0.9.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/WSME/WSME-0.9.3.ebuild b/dev-python/WSME/WSME-0.9.3.ebuild
new file mode 100644
index 000000000000..d926fa73e26c
--- /dev/null
+++ b/dev-python/WSME/WSME-0.9.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplify the writing of REST APIs, and extend them with additional protocols."
+HOMEPAGE="https://pythonhosted.org/WSME"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ dev-python/simplegeneric[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+"