summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-22 09:02:04 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-22 09:30:09 +0100
commit4ec98f3a67124f6dc02a9f460cc60377c2bcfe0e (patch)
tree11f4d15b9e17fd21af20f2ce85a3cc8a9f4f3cd1 /dev-python/agate
parentdev-python/apispec: Bump to 6.3.1 (diff)
downloadgentoo-4ec98f3a67124f6dc02a9f460cc60377c2bcfe0e.tar.gz
gentoo-4ec98f3a67124f6dc02a9f460cc60377c2bcfe0e.tar.bz2
gentoo-4ec98f3a67124f6dc02a9f460cc60377c2bcfe0e.zip
dev-python/agate: Bump to 1.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/Manifest1
-rw-r--r--dev-python/agate/agate-1.9.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index 916ef4dc99e8..2103b189225f 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1 +1,2 @@
DIST agate-1.9.0.tar.gz 202237 BLAKE2B f4a6609f843b0b0499b44c6596c186198e2d6a0c964727fbd3d3fa69bd6164a067384354e3426a0276f91fc3b6f2d1fc86e05e4d4be974d1f2c223b20cb5a6b3 SHA512 bbd05b503d27e34625cebba71c0d3a1362bf63c45a3ce7c327fb73f0730b739fe8f9bf780c37c4e1a0e70c9d263d9191946fa6b70c147c0761a43ed479ae7fed
+DIST agate-1.9.1.tar.gz 202303 BLAKE2B a5e62ca5fdf8dc6e1b7393da3efa0432a2d7a89bcb2af744458ae04446ea85941968f1ee75facc6b29de9fdec92f9432d2b939392edbfadc5c0598a91feb9f76 SHA512 f8bbe9ed24c786063a1d99aa408a2e5b4841dd9d804004b8c74a272d564432013e0ddebc5325e73893c53a60636d64f27f2e64ad624a468a070cf6a8833b8620
diff --git a/dev-python/agate/agate-1.9.1.ebuild b/dev-python/agate/agate-1.9.1.ebuild
new file mode 100644
index 000000000000..3452927edab1
--- /dev/null
+++ b/dev-python/agate/agate-1.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)