summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-01 03:35:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-01 03:44:44 +0200
commitbf4735250e1e1f316513dac1c0adb04e93914bbd (patch)
treee9075fba3f6de784d0819bb4642c58d2da2c682d /dev-python/aiohappyeyeballs
parentdev-python/pyproject-fmt: Bump to 2.2.1 (diff)
downloadgentoo-bf4735250e1e1f316513dac1c0adb04e93914bbd.tar.gz
gentoo-bf4735250e1e1f316513dac1c0adb04e93914bbd.tar.bz2
gentoo-bf4735250e1e1f316513dac1c0adb04e93914bbd.zip
dev-python/aiohappyeyeballs: Bump to 2.3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohappyeyeballs')
-rw-r--r--dev-python/aiohappyeyeballs/Manifest1
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
index a0e51c867691..d5af98349517 100644
--- a/dev-python/aiohappyeyeballs/Manifest
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -1 +1,2 @@
DIST aiohappyeyeballs-2.3.2.gh.tar.gz 46204 BLAKE2B 85a050910181e7acd6520ae8126e6e1656b5d5e7d869bca481af5fe65b52bf1d4dc0502d2e0cce702c60dc9420757fc892a91a600a73925adce6990fc224bb1a SHA512 5638dabb06c9d0182e21371470d612ec78a1a8981a0720318b0f4fc0569b7c556adfba6297b5bec75726e106f5a6335acfb19bd5322e43e5ebc4f71d4457424c
+DIST aiohappyeyeballs-2.3.4.gh.tar.gz 54416 BLAKE2B ca3f34af2d20528c229b6beba0896a7a2e6dc86a83310c36163c2213232d3222e8ba9eafc23461c5d79fae7af6a06127691ddfb582e12c3d402ee452c42803a0 SHA512 75adf8164e287113fb176f5f814f929dac57834941ba83eeec4c2e9aa28585c4659bc18fe7d7b010e9f53ee81d3a5b3727175ed981d4ec846e6209428a2516eb
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.4.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.4.ebuild
new file mode 100644
index 000000000000..05fb16344a39
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}