summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-11-10 09:45:31 +0100
committerHanno Böck <hanno@gentoo.org>2020-11-10 09:45:31 +0100
commitda17e0b539ef23ec68758b7b27d0e1a2111479e1 (patch)
treea4ae3b4e5497b7516fc55ef18f7c9368f4a9042e /dev-python/aiosmtpd
parentdev-python/aiosmtpd: Add upstream metadata (diff)
downloadgentoo-da17e0b539ef23ec68758b7b27d0e1a2111479e1.tar.gz
gentoo-da17e0b539ef23ec68758b7b27d0e1a2111479e1.tar.bz2
gentoo-da17e0b539ef23ec68758b7b27d0e1a2111479e1.zip
dev-python/aiosmtpd: Bump and enable Python 3.9 + tests
Closes: https://bugs.gentoo.org/717046 Closes: https://github.com/gentoo/gentoo/pull/17997 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.9, Repoman-3.0.2
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest1
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.2.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
index b2aefcbf8873..bb4465d92f1f 100644
--- a/dev-python/aiosmtpd/Manifest
+++ b/dev-python/aiosmtpd/Manifest
@@ -1 +1,2 @@
+DIST aiosmtpd-1.2.2.tar.gz 170459 BLAKE2B abf178c28a21c25e8a7c7ed920c154f037aaa21da5d2dfa0ee8cae7d239d00d5a979eedfb3865e3de7e54e7da94ea8a1e6b5194681a2137ac7d8f0f69d82e3a6 SHA512 7ffc279a73685601496dbfffef30a78cc254a76f8c8fccd0c7b7efe41da66672f0d8662f302eb928e90eb8977b859cb7e713415d0aa5e93f369ef23bdff405fc
DIST aiosmtpd-1.2.tar.gz 51457 BLAKE2B c2dba38c5d5a243a65c332cb3b6bf85a124eb6ab9c3526d0ef57788eb7e24e64ec86c56eeaa57e5171631c8a965447f125366741b1d1c54fb48473da5123ed40 SHA512 520b0fae80423d3963d4f17ef393cc0ce9e342fd1237c909159706bfe1e13f27df849fbc14aa1c94ad02e7c9108308984b6f9e21c7dbddb09093ef00884983d8
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.2.2.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.2.2.ebuild
new file mode 100644
index 000000000000..d4488629282b
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ rm -r examples || die
+ distutils-r1_python_prepare_all
+}