summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-18 08:15:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-18 08:27:22 +0100
commitaed3cf56b357d2ddc5ee374aa0f059441e934899 (patch)
treeb9c1dd68c90a89d0d0b47218c33430c69cf9b169 /dev-python/apprise
parentdev-python/fakeredis: Bump to 2.26.2 (diff)
downloadgentoo-aed3cf56b357d2ddc5ee374aa0f059441e934899.tar.gz
gentoo-aed3cf56b357d2ddc5ee374aa0f059441e934899.tar.bz2
gentoo-aed3cf56b357d2ddc5ee374aa0f059441e934899.zip
dev-python/apprise: Bump to 1.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest1
-rw-r--r--dev-python/apprise/apprise-1.9.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index 8f66d188b53e..4af44c7b1f60 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1 +1,2 @@
DIST apprise-1.9.0.tar.gz 1753505 BLAKE2B 83dda79cb585387ba3fa0405126274c35bee20e40a91e699441f56341f411e16dd62ff73115e6cde42e0184afffcaa4cb0783e082d0b2c1ed59a58839cfe9c73 SHA512 9b1ebc18f1662cea35186ddf28182e5507d7faf6e13770a4d6448f129c9d4659665ddf502e0cc7e6bd2e67cda41ee94cd0898f53b986af0daae5f905ccdab2eb
+DIST apprise-1.9.1.tar.gz 1778862 BLAKE2B 5c2d919e7d2f105f0636de6495a7ab450551e6cb2fb806f6f28e8f0bc1370c88e1ed0f55bc350a9828def787a43694bc519020ab522c06b70b648e4aefc187dc SHA512 02b96e6bf88858631d62fef7215d25b383015e916f8031fa01c30a44bb15ff6afd9eb8198e99ce107072f2802db25f5abfa033bb2e9752f559b4c6c40f99ac80
diff --git a/dev-python/apprise/apprise-1.9.1.ebuild b/dev-python/apprise/apprise-1.9.1.ebuild
new file mode 100644
index 000000000000..ff298c31cd7b
--- /dev/null
+++ b/dev-python/apprise/apprise-1.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest