summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 19:17:07 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 19:17:27 +0200
commit1ba13926cb2af0826dfd0154f82cfa9a91f0cc5f (patch)
tree36e71ade2fa58477efdf6e74260e6ab35a80e046 /dev-python/argh/argh-0.26.2.ebuild
parentdev-python/iocapture: Initial import, test dep for argh (diff)
downloadgentoo-1ba13926cb2af0826dfd0154f82cfa9a91f0cc5f.tar.gz
gentoo-1ba13926cb2af0826dfd0154f82cfa9a91f0cc5f.tar.bz2
gentoo-1ba13926cb2af0826dfd0154f82cfa9a91f0cc5f.zip
dev-python/argh: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/argh/argh-0.26.2.ebuild')
-rw-r--r--dev-python/argh/argh-0.26.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/argh/argh-0.26.2.ebuild b/dev-python/argh/argh-0.26.2.ebuild
new file mode 100644
index 000000000000..f5245a0616e2
--- /dev/null
+++ b/dev-python/argh/argh-0.26.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="http://packages.python.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="LGPL-3"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}