summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-31 08:03:48 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-31 08:17:27 +0100
commit3ebc6f86d9db985adccc1a4fa13492a4d681702a (patch)
treee92e8d5b03d978f268d63ce21f187266df1a9e8d /dev-python/argh
parentdev-python/chameleon: Bump to 4.4.3 (diff)
downloadgentoo-3ebc6f86d9db985adccc1a4fa13492a4d681702a.tar.gz
gentoo-3ebc6f86d9db985adccc1a4fa13492a4d681702a.tar.bz2
gentoo-3ebc6f86d9db985adccc1a4fa13492a4d681702a.zip
dev-python/argh: Bump to 0.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest1
-rw-r--r--dev-python/argh/argh-0.31.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index bb933ee56341..484e1d1de177 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -1,2 +1,3 @@
DIST argh-0.30.4.tar.gz 62618 BLAKE2B e95ee9219d2b8079e4b9548f68811832ed9ca699c1dcfeabcf31a9a0c3fd35c107896f088a64efe430347fefd1424345753bc4e0341155a92d99a5327f4a137d SHA512 6a17fcaef3a1a400426cc53339e07583734b0b68ce9202a7b3655f5cababa495aa5269f66cde2d0b2217874ddb730bf7d1c7636dd915e4e778058399b9b9a44c
DIST argh-0.30.5.tar.gz 63041 BLAKE2B 3b8e928d1e6f8fd2340afa87072c35a04e4222dac7d3d549fa6040f3e1352365ff9d2b940d30f20b6aa0959a8331638e076e3f42fe7b16ff96be8734278db59c SHA512 74194010f0558335557a56ea9daa24a7301733090ffcbd201524b67727a64d8dabaeb31558f7da6f2bf51ab9354b371b09a0be55125bcaee128630df59343188
+DIST argh-0.31.0.tar.gz 65743 BLAKE2B c577273bf361b0bede939b7bcadf9c9ce6dd24d473b834ebd8d2bdc41d163e9cb6f2b79252ab810ac5b6f1f2e20b312cf096b23cf6cd4cd53705fb2c30b55f7d SHA512 d4caefede2596452d3256f4c2194517994dffdb2e01643f0b96b8002d269ac0150e938bb29d0469b67bbb72669b2a82b3e66d28cfecad5230f641c60f1c879e5
diff --git a/dev-python/argh/argh-0.31.0.ebuild b/dev-python/argh/argh-0.31.0.ebuild
new file mode 100644
index 000000000000..32a100a7ba11
--- /dev/null
+++ b/dev-python/argh/argh-0.31.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest