summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-18 23:59:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-19 01:40:32 +0100
commit3bf5f628129d0d08cee773c73a818668217702a6 (patch)
tree274f28624064fda47383e0e0ad5b82912079abb9 /dev-python/asgiref/asgiref-3.3.1.ebuild
parentdev-python/hypothesis: Bump to 5.41.3 (diff)
downloadgentoo-3bf5f628129d0d08cee773c73a818668217702a6.tar.gz
gentoo-3bf5f628129d0d08cee773c73a818668217702a6.tar.bz2
gentoo-3bf5f628129d0d08cee773c73a818668217702a6.zip
dev-python/asgiref: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asgiref/asgiref-3.3.1.ebuild')
-rw-r--r--dev-python/asgiref/asgiref-3.3.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/asgiref/asgiref-3.3.1.ebuild b/dev-python/asgiref/asgiref-3.3.1.ebuild
new file mode 100644
index 000000000000..2a8bf860303e
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest