summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-04-03 21:15:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-04-03 21:15:03 +0300
commit8c47574171692a7902b4fcff77fadaf9f8801b8f (patch)
tree2527989fd6428869b6a8c0c9f0f295cb228f5c32 /dev-python/astroid
parentdev-python/aws-xray-sdk-python: add 2.12.0 (diff)
downloadgentoo-8c47574171692a7902b4fcff77fadaf9f8801b8f.tar.gz
gentoo-8c47574171692a7902b4fcff77fadaf9f8801b8f.tar.bz2
gentoo-8c47574171692a7902b4fcff77fadaf9f8801b8f.zip
dev-python/astroid: add 2.15.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.15.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index de7c914342e6..8ab45fc8fc0e 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -4,3 +4,4 @@ DIST astroid-2.14.1.gh.tar.gz 452889 BLAKE2B f6cee61825d2c86bbf02ba6cc9f48076692
DIST astroid-2.14.2.gh.tar.gz 453109 BLAKE2B cb4b0795bde841e98712a719ba0870a3f0c616fc777cb3afc1ebbb0f5e49b763241825072d7915df87e778649a5632fec8f48e125cfa67de0b70618e34509157 SHA512 2dad27c0a3ddad5747a021c0700b831fe9f7a557238a2f52d87722c637120d49796a0a8e9e6f27d42ab4bee1c91541b7b5b5fa93dc3ec8a47197f35569a64a3a
DIST astroid-2.15.0.gh.tar.gz 460733 BLAKE2B cc80ffd9b5804a1a0c94598f75363088dcb971ee322b556e150799a5e18aa16d20c58d9bf7725c2697d34152daa72a20d845e7c56a524d58354913eed338010f SHA512 7ec121b3c7d60e2d48f738fbc4eeae3e32c7135a77fb778db9479d730a757818f549d8bd35facdd67d411d777d57ec620a2448de1f4da23754863cae18717bce
DIST astroid-2.15.1.gh.tar.gz 460960 BLAKE2B ec08cc53027323a70291adc888b3621dc139783e6f72859eac05a2c6da0150cc5d19dc6a7278b6a846f985cf44c7d868df1ba11d0c6e3b7a5d3c71a38603743e SHA512 26f85aff9de08d4b413c40951f2aefd2c19304c077b502774b253e3fcced42173bc7e996fac82b3462c6915625ff48fd80dd1ab5e3425aefa103347f821f7df4
+DIST astroid-2.15.2.gh.tar.gz 461132 BLAKE2B 1e4d5fa174c7893743ebe9a17b28bdee68fefd35a69802358eb4448402a00622ec56a7ba18a8cdae8cafd9e75bbee9cd18f39bbb44fbcc061c893fc24e308376 SHA512 aea2a55780f81893d8dad4acb572883017e3d6270d48a8f0d3b4520279bc4d79e9d04192479d5aad453ab7bda6d29edf1f56c92d86c04a8ef07bd4561bf908c4
diff --git a/dev-python/astroid/astroid-2.15.2.ebuild b/dev-python/astroid/astroid-2.15.2.ebuild
new file mode 100644
index 000000000000..9ad352280874
--- /dev/null
+++ b/dev-python/astroid/astroid-2.15.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why they're broken
+ tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
+ tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
+ # some problem with warnings (our options?)
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
+ # requires six bundled in urllib3, sigh
+ tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}