summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-23 20:41:55 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-23 20:42:13 +0000
commit3f75cba317d5fae3b2035d5b55b68be2e87cff01 (patch)
treeca7d62fb1db83aaff3ad5a0750b2418b5c18889a /dev-python/astropy
parentmedia-tv/kodi: drop old 15.1 ebuild (diff)
downloadgentoo-3f75cba317d5fae3b2035d5b55b68be2e87cff01.tar.gz
gentoo-3f75cba317d5fae3b2035d5b55b68be2e87cff01.tar.bz2
gentoo-3f75cba317d5fae3b2035d5b55b68be2e87cff01.zip
dev-python/astropy: fix for EAPI6 doc building
Documentation build fix, and using newer python-r1 routines. Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=575222 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/astropy')
-rw-r--r--dev-python/astropy/astropy-1.1.1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/astropy/astropy-1.1.1.ebuild b/dev-python/astropy/astropy-1.1.1.ebuild
index cbe12838cef2..656fb4aaa6a9 100644
--- a/dev-python/astropy/astropy-1.1.1.ebuild
+++ b/dev-python/astropy/astropy-1.1.1.ebuild
@@ -33,8 +33,8 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
virtual/pkgconfig
doc? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/matplotlib[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python2_7)
media-gfx/graphviz
)
test? (
@@ -45,6 +45,8 @@ DEPEND="${RDEPEND}
sci-libs/scipy[${PYTHON_USEDEP}]
)"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
PATCHES=(
"${FILESDIR}/${PN}-1.0.4-system-six.patch"
"${FILESDIR}/${PN}-1.0.4-system-configobj.patch"
@@ -52,6 +54,10 @@ PATCHES=(
"${FILESDIR}/${PN}-1.1.1-mark-kown-failures.patch"
)
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_prepare_all() {
export mydistutilsargs="--offline"
export ASTROPY_USE_SYSTEM_PYTEST=True
@@ -60,17 +66,15 @@ python_prepare_all() {
rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
sed -i -e '/auto_use/s/True/False/' setup.cfg || die
cat >> setup.cfg <<-EOF
-
[build]
use_system_libraries=1
EOF
-
distutils-r1_python_prepare_all
}
python_compile_all() {
if use doc; then
- python_export_best
+ python_setup "python2*"
VARTEXFONTS="${T}"/fonts \
MPLCONFIGDIR="${BUILD_DIR}" \
PYTHONPATH="${BUILD_DIR}"/lib \