summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-21 16:13:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-21 16:16:26 +0200
commit796ea7275d64ca9ba0bf262a89fdf47af9518fab (patch)
tree98e1f654db20373298231ea7fd9b315deb01bff0 /dev-python/atpublic
parentmedia-libs/libjxl: fix live ebuild (diff)
downloadgentoo-796ea7275d64ca9ba0bf262a89fdf47af9518fab.tar.gz
gentoo-796ea7275d64ca9ba0bf262a89fdf47af9518fab.tar.bz2
gentoo-796ea7275d64ca9ba0bf262a89fdf47af9518fab.zip
dev-python/atpublic: Bump to 3.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/atpublic')
-rw-r--r--dev-python/atpublic/Manifest1
-rw-r--r--dev-python/atpublic/atpublic-3.0.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/atpublic/Manifest b/dev-python/atpublic/Manifest
index bcc1aa4fd210..e8623fef8ca3 100644
--- a/dev-python/atpublic/Manifest
+++ b/dev-python/atpublic/Manifest
@@ -1 +1,2 @@
DIST atpublic-2.3.tar.gz 16746 BLAKE2B 60d12db8c56f3e3ce45c2e300759334b662369980b3dc36bff1edbac2d4a13dcf1bd390725eac488969d5a80e5ee5bb598c80e31ed3667c2e7d4f1f88fd00f7c SHA512 88c140c7ca0cfe3db791fd43a97f9fc63de979191a026df4d9f7a34a347b657d7d7b6fb7e31a231ac3adbc5e5d014b8e3c3606b93515a6ad42ea3d101b480329
+DIST atpublic-3.0.1.tar.gz 14131 BLAKE2B 3912c23c5ee575d7bdec1b598f1f360c54296211600115a413d97c73751b5301b2f3d22152aa62d4d7ac6da9a6cf4202a2deba1de374407ede4358620ee97391 SHA512 02c4af8aa02040bba2f09b852e17a0a90c0a6dce8fdabc8362a67c2f326b68369bf5f12f91291f9ff3395685530592561b132f09f9869867516592bd092e0e38
diff --git a/dev-python/atpublic/atpublic-3.0.1.ebuild b/dev-python/atpublic/atpublic-3.0.1.ebuild
new file mode 100644
index 000000000000..3985ada854dc
--- /dev/null
+++ b/dev-python/atpublic/atpublic-3.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A decorator to populate __all__ and the module globals"
+HOMEPAGE="
+ https://gitlab.com/warsaw/public/
+ https://pypi.org/project/atpublic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/sybil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}