summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-29 23:46:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 00:14:53 +0100
commiteddf85c5eea6e4e19b430db56403070178957e61 (patch)
tree2d88a09e51d2a6be3283f3aa4926fb6df5db4a9b /dev-python/attrs
parentdev-python/psycopg: Bump to 2.9.3 (diff)
downloadgentoo-eddf85c5eea6e4e19b430db56403070178957e61.tar.gz
gentoo-eddf85c5eea6e4e19b430db56403070178957e61.tar.bz2
gentoo-eddf85c5eea6e4e19b430db56403070178957e61.zip
dev-python/attrs: Bump to 21.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest1
-rw-r--r--dev-python/attrs/attrs-21.4.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index 34e7f1b2225f..968692af20b1 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,2 +1,3 @@
DIST attrs-21.2.0.tar.gz 184694 BLAKE2B 5c960f7c1a4623186c7a0cec8a9096df8df8e7d3022b67b281dcdd3a512ce6f105dfdd5ec10dc85a2b9971564f44e7b4474d760667e53cd2cf0f0543153eb6e2 SHA512 35863f599076357e40f72a62968f4a2f9bc2af9f59f484fef051be4f9730ce9e28e11568915d690ade7980df8998af22e2ff8b9568a205d7745e246ba5f3a7e1
DIST attrs-21.3.0.tar.gz 204413 BLAKE2B 1aac1198196aa3438eb1ec9dac0a4971362caea655e27a2b7811e48d500a40fe8f2daf43ce86d3b381892763fdfecf9adbda16a29dda57155ec5a588732b423d SHA512 23b2ba52af809581e9907ad7c6d18ed050d415645a249ae912af3f1398276ea5bf67f11991d7958f3eeafe759d8d62a65009555ae8f75580cfa464c5b4a37742
+DIST attrs-21.4.0.tar.gz 201839 BLAKE2B f8e9ca1385efe6f5b9bf468f622f0bf5390830c5f3c3526821446113146a61460b17e8750ea763f6da50221a8aa65f5f1ff98a6ddf69b1a87344508ca6495560 SHA512 5a52776eb505c8a354912fa037a9710e49830fa6ad37272cb6d8c3298f4179a5b237e36cd7db3b1c9af19fbf0194ad6b83c3db9a473f9349769180073273ba65
diff --git a/dev-python/attrs/attrs-21.4.0.ebuild b/dev-python/attrs/attrs-21.4.0.ebuild
new file mode 100644
index 000000000000..3a574f7a749c
--- /dev/null
+++ b/dev-python/attrs/attrs-21.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs/
+ https://attrs.readthedocs.io/
+ https://pypi.org/project/attrs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ $(python_gen_cond_dep '
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ ' 'python*')
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest