summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-13 22:06:18 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-13 22:06:18 -0400
commit2ca5a448254b8e6488678323db09c07dd7480829 (patch)
tree2b441373e3384b4709ac6ea7cbb8befdb3b7ecba /dev-python/autopep8
parentdev-python/ropemode: version bump to 0.4 (diff)
downloadgentoo-2ca5a448254b8e6488678323db09c07dd7480829.tar.gz
gentoo-2ca5a448254b8e6488678323db09c07dd7480829.tar.bz2
gentoo-2ca5a448254b8e6488678323db09c07dd7480829.zip
dev-python/autopep8: remove old
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest2
-rw-r--r--dev-python/autopep8/autopep8-1.0.4.ebuild41
-rw-r--r--dev-python/autopep8/autopep8-1.2.4.ebuild34
3 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index dc1c6d890067..4983cd35f455 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,3 +1 @@
-DIST autopep8-1.0.4.tar.gz 121476 SHA256 58883a80d501f6f5d97859f100414c6b6f6131fcfc08bd88364c2ecb37a55153 SHA512 53e902dcdd654b9d67d9a31a2343503b754bec78630a7fd8d229843c53eb27d11c32fd6a4829714ac4d7cbee59b055d12e60453ae4ee01cb6131bf9c5045426f WHIRLPOOL 44748dfce6202e1e82c468862e4505500c939ee88eb474392767e606c537a66736f2788c0b6573db37b7c207f3f4608b2a6ecb0fb231bb8c3c090040d17f0642
-DIST autopep8-1.2.4.tar.gz 105273 SHA256 38e31e266e29808e8a65a307778ed8e402e1f0d87472009420d6d18146cdeaa2 SHA512 f56c143d94521487628b225d9a0464ee5c8ca69aaea0c5e43c84f1dd920a0274508c6831da429e716829c38bc7c357842bb6403b8b61c04b464240e3573e05d6 WHIRLPOOL f551f8e2cb8b71664c2e47f7458c9923b70b420c044f980d67172b17f7ea9aa328141f9af648eedb400379dfb5a6ab804671fb1f942f8cca8a3ad851a5e9b3d2
DIST autopep8-1.3.2.tar.gz 107915 SHA256 7e82590bf366b4d891ac5c1535554c46a5f79e4400a190a8493e92e75c5037dd SHA512 cb9a5e297ce705722d5e65472dbe749e57fa12fe8dee0d4c3dc20d9e885e0d885339627667110318c89c6bf7e337203a7831c0e2217e5a5d7951edcb98d3df4f WHIRLPOOL 8e1d4a9a71e4cc790060a393f5512913d567855d886776b4e32db4ffcef0bb82c793b3af833ddec1dc0f08e585f2d9163ec1c8ee67f118f4b982740ffec89f6e
diff --git a/dev-python/autopep8/autopep8-1.0.4.ebuild b/dev-python/autopep8/autopep8-1.0.4.ebuild
deleted file mode 100644
index 8a53ef142c0a..000000000000
--- a/dev-python/autopep8/autopep8-1.0.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.python.org/pypi/autopep8"
-SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND=">=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_prepare_all() {
- # Prevent UnicodeDecodeError with LANG=C
- sed -e "/é/d" -i MANIFEST.in || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
-
-pkg_postinst() {
- ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
- ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
- ewarn "(indentation checks inside triple-quotes)."
- ewarn "If you do not want to be affected by this, then add the"
- ewarn "following lines to your local package.mask:"
- ewarn " >=dev-python/pep8-1.3"
- ewarn " >=dev-python/autopep8-0.6"
-}
diff --git a/dev-python/autopep8/autopep8-1.2.4.ebuild b/dev-python/autopep8/autopep8-1.2.4.ebuild
deleted file mode 100644
index fd5e219da4d3..000000000000
--- a/dev-python/autopep8/autopep8-1.2.4.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.python.org/pypi/autopep8"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Prevent UnicodeDecodeError with LANG=C
- sed -e "/é/d" -i MANIFEST.in || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}