summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-16 21:31:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-16 21:31:03 +0100
commit9cf124a820897591238ac53b14bf713b5e77909d (patch)
tree63e82f32f7e0a1b0d4d4023ab8d8d480903d0cc6 /dev-python/autopep8
parentdev-python/alabaster: Remove old (diff)
downloadgentoo-9cf124a820897591238ac53b14bf713b5e77909d.tar.gz
gentoo-9cf124a820897591238ac53b14bf713b5e77909d.tar.bz2
gentoo-9cf124a820897591238ac53b14bf713b5e77909d.zip
dev-python/autopep8: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-2.0.0.ebuild42
-rw-r--r--dev-python/autopep8/files/autopep8-1.6.0-lib2to3-deprecation-pytest.patch28
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 97b274a5f387..701dca14bc07 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,2 +1 @@
-DIST autopep8-2.0.0.tar.gz 117507 BLAKE2B 8722b19454f47d0b960e3cc0e18ff3d6150ead009630047ecd1ce9001ea6f6d68595f80d7ad1087bddd2993e95d0634d63495b1d43dee095d114535bf632d1bf SHA512 883b79f7011a374a2ef88073a45748268a20449a3bc8da519c036c71700352dd8c4accc60fcb592f1a53ceac06984fcbe6ede8a272bc718c2b79873be5f35dd8
DIST autopep8-2.0.1.tar.gz 115905 BLAKE2B 9dde8d702a0b21fb1457e08120dca805e2b46e3e5284e5d98932ff93afc4c0ac8dbc60215f35b64d4a308d6748df1411c2979d8fa1f4949b1dbe213bf19de9dc SHA512 cc0e8e5b7228ba9b37adaa3b2689a5e1ad04eb84366c5300d7a220b1593a64e4f1dc332750f8ca53935dec6a3ea1d07cae5615373e44da357a980d9763bbc3f1
diff --git a/dev-python/autopep8/autopep8-2.0.0.ebuild b/dev-python/autopep8/autopep8-2.0.0.ebuild
deleted file mode 100644
index 162c3d53396b..000000000000
--- a/dev-python/autopep8/autopep8-2.0.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="
- https://github.com/hhatto/autopep8/
- https://pypi.org/project/autopep8/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm64 ~ia64 ppc sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # test require in source build
- test/test_autopep8.py::SystemTests::test_e101_skip_innocuous
-)
-
-PATCHES=(
- "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
-)
diff --git a/dev-python/autopep8/files/autopep8-1.6.0-lib2to3-deprecation-pytest.patch b/dev-python/autopep8/files/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
deleted file mode 100644
index 9aadf2758c0c..000000000000
--- a/dev-python/autopep8/files/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/test/test_autopep8.py 2022-07-01 16:53:14.197393816 +0300
-+++ b/test/test_autopep8.py 2022-07-01 17:26:07.740358186 +0300
-@@ -5729,7 +5729,11 @@
- list(AUTOPEP8_CMD_TUPLE) + [filename, '--in-place'],
- stderr=PIPE,
- )
-- _, err = p.communicate()
-+ _, error = p.communicate()
-+ if b'DeprecationWarning: lib2to3 package is deprecated' in error:
-+ err = bytes()
-+ else:
-+ err = error
- self.assertEqual(err, b'')
- self.assertEqual(p.returncode, autopep8.EXIT_CODE_OK)
-
-@@ -5741,7 +5745,11 @@
- list(AUTOPEP8_CMD_TUPLE) + [filename, '--in-place'],
- stderr=PIPE,
- )
-- _, err = p.communicate()
-+ _, error = p.communicate()
-+ if b'DeprecationWarning: lib2to3 package is deprecated' in error:
-+ err = bytes()
-+ else:
-+ err = error
- self.assertEqual(err, b'')
- self.assertEqual(p.returncode, autopep8.EXIT_CODE_OK)
-