summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-09 08:08:48 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-09 08:32:31 +0200
commit2f32b0a219c331571c9035b3f472e4c4a1584e9a (patch)
tree57e127e1e7f79b4d18c8611d85bae7ef271dcfeb /dev-python/beautifulsoup4
parentdev-python/osrf_pycommon: Bump to 2.0.2 (diff)
downloadgentoo-2f32b0a219c331571c9035b3f472e4c4a1584e9a.tar.gz
gentoo-2f32b0a219c331571c9035b3f472e4c4a1584e9a.tar.bz2
gentoo-2f32b0a219c331571c9035b3f472e4c4a1584e9a.zip
dev-python/beautifulsoup4: Bump to 4.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest1
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.11.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index f27894a8549e..337f309ccf28 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1 +1,2 @@
DIST beautifulsoup4-4.10.0.tar.gz 399890 BLAKE2B 61f044064a81e94b64a72fd49cca164faa05442bc76f897c8a7fa4481acca039bcb9e4f7a1853a7155504fa25e56c518806d8af016369bc37316ecb95b59d7d3 SHA512 92be99ed0fd479b86519395143516e28f7b80f54a8251223d6e7b88dc98f8dfca9585079f5f1d89bfe68f577de3dff433711642486303203f46bc76754959a18
+DIST beautifulsoup4-4.11.1.tar.gz 517113 BLAKE2B bc0cc8dbb1bffca2d3441a274147f201b79447f2147f7b4c329f05f6d230f9986eebd3709199d0b3c7dba8c15e4ce42e9dc75e290a2bfdfdae643f5dfe07e767 SHA512 7446be07cd55f23def929e6491f0d74a940cf50206ed520b8ae7b9d57bd19ecf6aa821f446ca4f26f1e08b43fcc71fb397886f51a3f0ec691f9e53dfdc7a0cf8
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.11.1.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.11.1.ebuild
new file mode 100644
index 000000000000..e419a3f8ed3f
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.11.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source