summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-23 04:58:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-23 05:03:43 +0100
commit60271bcc754b61f105b8e044a6c65e23a13c5196 (patch)
treebac97ec329f1e0d85e7368a36a3448ffc8c29f67 /dev-python/bitstring
parentdev-python/tekore: Bump to 5.2.1 (diff)
downloadgentoo-60271bcc754b61f105b8e044a6c65e23a13c5196.tar.gz
gentoo-60271bcc754b61f105b8e044a6c65e23a13c5196.tar.bz2
gentoo-60271bcc754b61f105b8e044a6c65e23a13c5196.zip
dev-python/bitstring: Bump to 4.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bitstring')
-rw-r--r--dev-python/bitstring/Manifest1
-rw-r--r--dev-python/bitstring/bitstring-4.1.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/bitstring/Manifest b/dev-python/bitstring/Manifest
index c70f6d6d8817..9ac28bad4fc6 100644
--- a/dev-python/bitstring/Manifest
+++ b/dev-python/bitstring/Manifest
@@ -1,2 +1,3 @@
DIST bitstring-4.1.1.tar.gz 228708 BLAKE2B f883fc0e40fd426a21449ca27ce58b7e40291f3758aee70cfe455ea3db7cd22c32ae74f581e5a2c99f21e8162c9499793891074750a5b81a8397c5333fd18210 SHA512 dd90382f57a9a8eda41616d61ba589f1504a6613ef36104b1187c345197cf088c4ef1c283af8a33ce629bfeea2d39065970d173051d67f3ec2e2240043869ff8
DIST bitstring-4.1.2.tar.gz 232896 BLAKE2B 549942afafc0a8c3c5ad30b835acbfb6e800514be5c3d0a132a4dc026eb80168a0d42a530be1c652e97cb4b2eefbd0dc834b3d2e782b137a075f1e6e6a14a016 SHA512 23e5f651538b06c6342dd661661382b8935271d6266e6ad2404e19c0af49ca2756337793e66d858731421246fad5330f2f5588bee3e81cc8ca39a985c2941721
+DIST bitstring-4.1.3.tar.gz 231483 BLAKE2B 54b6b8e3f1331a3aadc0b06f33a4353126c4f96ce087a3c74c05f74f67148e12ad019551e625b59478aa46e6856a788c1700db24f738d41423b86b306739f932 SHA512 57e247a019c89179f258fbf34454ec812a0e87aacec9cbad9b7166afc130629878ac6f40987380906ae2f2c3175999e2fa7a071d87f607ba2d9301100aee9263
diff --git a/dev-python/bitstring/bitstring-4.1.3.ebuild b/dev-python/bitstring/bitstring-4.1.3.ebuild
new file mode 100644
index 000000000000..ed11001fdc22
--- /dev/null
+++ b/dev-python/bitstring/bitstring-4.1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python module for creation and analysis of binary data"
+HOMEPAGE="
+ https://github.com/scott-griffiths/bitstring/
+ https://pypi.org/project/bitstring/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/bitarray-3[${PYTHON_USEDEP}]
+ >=dev-python/bitarray-2.8.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest