summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-06 04:37:00 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-06 05:30:52 +0200
commit03151a8c3c5120227d5301307941f4efb0ad586c (patch)
tree086c0ec7779c16fba9f05611af46c7ed94292fef /dev-python/boto3
parentdev-python/botocore: Bump to 1.30.1 (diff)
downloadgentoo-03151a8c3c5120227d5301307941f4efb0ad586c.tar.gz
gentoo-03151a8c3c5120227d5301307941f4efb0ad586c.tar.bz2
gentoo-03151a8c3c5120227d5301307941f4efb0ad586c.zip
dev-python/boto3: Bump to 1.27.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.27.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2e441ca2c95e..d565cc9b3755 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.26.163.gh.tar.gz 670006 BLAKE2B c2bcd2a3a4aaf1f2f5b69a605971ee62a09
DIST boto3-1.26.164.gh.tar.gz 670774 BLAKE2B d5a1f93ac403e738b754a915f6d64f16c083aa604cc535d33ca00c5484b3ff99a64b80173b0b1d60222e5cc797039d4135a767dab1284b0b16e913e2afcf00aa SHA512 165b779c667f7d6f53c4849e215425f9cd717923df582215a6966b0f30b81014c8e804d24072623c8210fae1c702c38c9331cc6d90903d2d270a9060318f3c08
DIST boto3-1.26.165.gh.tar.gz 671248 BLAKE2B b9c390bb2a32fa75fc48258137f04961d54c269f78ac8a87ef5d5eb24aada8708c341f89051b8c8e5d306b7e0c59ebc128659bcf89e071c479edf9cb7b959a5c SHA512 734df5b6301eca682c0ae1f6bdda3024ed7171d3ed9952f24d177454fb19653b9bd573d9b9a09f44a9324163190620c72623f1f7f20706af42eecf5026e9f853
DIST boto3-1.27.0.gh.tar.gz 671636 BLAKE2B 1a3927db8c67b066108b03a9018522b73f6b2ee95f7aaaad278a3e04c0e785764148e6b86ab63804acc035112df13203aa853f435d95e0a647ce8a83f4ca3504 SHA512 11a438c2cd9d55bada47575b784f151ff4ae1ad9520c6cbda2edfc2a0b2cfefbac231c11b977bcfbe031d0fc813a663b59cd29a04aeb6376fb9d4869d69feed7
+DIST boto3-1.27.1.gh.tar.gz 672067 BLAKE2B 63bc6fcb40c3623d84cdd5e21cb656f7ba0335e06c45c7ffe652bece36f7bbf0ddaf4d52b98625d31851b63f646abecf79eac727a35a31e6f58410def3be4289 SHA512 e3b339459a2ae221d8aefb4c540bfae6ec9fc5ec27b623c66d894aef5e50873b57ed6dd12b356b32a4c30aef3e8d98c4c43bbbb629033c850604ef2bfa6cb715
diff --git a/dev-python/boto3/boto3-1.27.1.ebuild b/dev-python/boto3/boto3-1.27.1.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.27.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}