summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-19 07:31:09 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-19 08:34:11 +0200
commit056612cdc2941624814786be3a651661a71100b4 (patch)
tree582b40fed0c9adeca5d8672a90cb8c3cfdda6f45 /dev-python/boto3
parentdev-python/botocore: Bump to 1.21.24 (diff)
downloadgentoo-056612cdc2941624814786be3a651661a71100b4.tar.gz
gentoo-056612cdc2941624814786be3a651661a71100b4.tar.bz2
gentoo-056612cdc2941624814786be3a651661a71100b4.zip
dev-python/boto3: Bump to 1.18.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.24.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 5d513726a2ec..b1b86b24b8e3 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,4 +3,5 @@ DIST boto3-1.18.15.tar.gz 400374 BLAKE2B 2170319480578b9ac7b6c0da9e9a2f256ce907b
DIST boto3-1.18.21.tar.gz 402611 BLAKE2B 39974c66ed5ad0697be6df04dbb141ce28e9a09863349f7adfcf756666d58ed02232453a9d86d46e62380c0b7f197a52b6869469309dff0c532e50a6bfc88403 SHA512 9920891b7be9d98c3a3d2f3065183532624e78fd2ff7a94d26594d2499cd5d17db0ac4ba6adf27f0e0f67fa836020dfac648babc144e4339a3dd717a1bd56ef7
DIST boto3-1.18.22.tar.gz 403212 BLAKE2B 82ee003adf55339ef956182287220d4c2bbafe371676ff94ca73f8cc95c484de86f1a9ae32a64d532e3731efeed486b9486d9591c3ee3a76d3a74d2fae22ec88 SHA512 f5abd2169adbc0d9edc28f6d8e5165c7c0587c387b3a71a40483b3bb4d90752d745dc0bbc58bda5470bd6fd68675f0eff3c1fa5e889fb231956c47a81a353b79
DIST boto3-1.18.23.tar.gz 403993 BLAKE2B 060f556e7787c02bf34cb18ac950217bfc105773295836c35893c09a132a295faf219d5b39b80d7b7174b9a612ce5067d69838f2bbd2f99a87b117267c4663e1 SHA512 18fe36d7c4a9ec8b1bb008c1da1e9f26f455cd88ce0db3ead760bb328a4190111832c0e5b9b155382d540b3c788ad97ea796afd099de527f2df626571f50db5b
+DIST boto3-1.18.24.tar.gz 404333 BLAKE2B fd0857a3462485a8cb633888ad6cae1578f32f7ef80ca5195e4b4953d2a4767baa41ce824eda5cb71211675529eb54b7d8d3ad42f1ec79a0b2cef847b13cdaee SHA512 c3e67c62bdf24d177c27d187eacb1118a7f221cb0143c72c6307af489bf9fe5358e2bde9f7d5f03ef9782a50faa17f31e57832ebc2f5dc73d1278c3eefc6cc3b
DIST boto3-1.18.7.tar.gz 395640 BLAKE2B 6a9fa1dd55644806fe93271805f35fbe0c4cb65d1de08dded2d2f57fcefa96e32c4ebe7b60743c52c0898222bc06d33dbd03d304bbef327b88022450a7943e2c SHA512 20e7fedab7d061ab02f391e9baf36cb554e7f194f38d24d5a75f76715b2acf1b51b6adce5d8cf5a2a0d29df73566db00b8813a219d45a194d9a8eb93d0dab570
diff --git a/dev-python/boto3/boto3-1.18.24.ebuild b/dev-python/boto3/boto3-1.18.24.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.24.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}